Cloudreve: Privilege Scope Bypass: State-Mutating Admin Operations Accessible via Read-Only OAuth Scope
CVE-2026-77637GHSA-w89x-c962-c44g
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/cloudreve/Cloudreve/v3
- Affected
- every version
- Fixed in
- no fixed version recorded
Go github.com/cloudreve/Cloudreve
- Affected
- every version
- Fixed in
- no fixed version recorded
Go github.com/cloudreve/Cloudreve/v4
- Affected
- < 4.0.0-20260715070110-bce08f88e9d8
- Fixed in
- 4.0.0-20260715070110-bce08f88e9d8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6576 lists affected ranges: Go github.com/cloudreve/Cloudreve >=0; Go github.com/cloudreve/Cloudreve/v3 >=0; Go github.com/cloudreve/Cloudreve/v4 >=0 <4.0.0-20260715070110-bce08f88e9d8 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w89x-c962-c44g lists affected ranges: Go github.com/cloudreve/Cloudreve/v4 >=0 <4.0.0-20260715070110-bce08f88e9d8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w89x-c962-c44g lists affected ranges: Go github.com/cloudreve/Cloudreve/v4 >=0 <4.0.0-20260715070110-bce08f88e9d8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-77637: 0.33% estimated exploitation activity in the next 30 days; percentile 25.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There is a privilege scope bypass in Cloudreve's admin API where two endpoints that mutate server state are missing the write-scope enforcement that their neighboring endpoints correctly apply. Specifically, the WOPI configuration fetch endpoint and the SMTP test/mail endpoint can both be triggered by an OAuth token that only has Admin.Read authorization — no Admin.Write needed. This breaks the intended OAuth scope boundary in a way that's subtle enough to have slipped through but meaningful enough to matter in a real deployment. Details The root cause is an inconsistency in how the admin tool routes are wired up in routers/router.go. The admin route group sets a baseline of ScopeAdminRead for everything underneath it (around line 868), and most write-capable endpoints inside the tool sub-group correctly layer on an additional RequiredScopes(types.ScopeAdminWrite) check on top of that. For example, the thumbnail executable setter (line 929) and the entity URL cache deletion…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w89x-c962-c44g
- Revision 2 · amended ·
Amended from osv record GO-2026-6576
- Revision 1 · created ·
Published from osv record GHSA-w89x-c962-c44g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-77637 Advisory: Cloudreve: Privilege Scope Bypass: State-Mutating Admin Operations Accessible via Read-Only OAuth Scope IDs: CVE-2026-77637, GHSA-w89x-c962-c44g Record: https://patchnext.com/advisories/cve-2026-77637 (revision 3, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/cloudreve/Cloudreve/v4 4.0.0-20260715070110-bce08f88e9d8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cloudreve/Cloudreve/v3: affected every version - Go github.com/cloudreve/Cloudreve: affected every version - Go github.com/cloudreve/Cloudreve/v4: affected < 4.0.0-20260715070110-bce08f88e9d8; fixed in 4.0.0-20260715070110-bce08f88e9d8 ## Suggested inspection (read-only) - Go github.com/cloudreve/Cloudreve/v3: check the installed version with your package manager. - Go github.com/cloudreve/Cloudreve: check the installed version with your package manager. - Go github.com/cloudreve/Cloudreve/v4: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cloudreve/Cloudreve/v3, github.com/cloudreve/Cloudreve, github.com/cloudreve/Cloudreve/v4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6576 (OSV record GO-2026-6576 lists affected ranges: Go github.com/cloudreve/Cloudreve >=0; Go github.com/cloudreve/Cloudreve/v3 >=0; Go github.com/cloudreve/Cloudreve/v4 >=0 <4.0.0-20260715070110-bce08f88e9d8 (fixed)) - Verified: https://osv.dev/vulnerability/GHSA-w89x-c962-c44g (OSV record GHSA-w89x-c962-c44g lists affected ranges: Go github.com/cloudreve/Cloudreve/v4 >=0 <4.0.0-20260715070110-bce08f88e9d8 (fixed)) - Verified: https://github.com/advisories/GHSA-w89x-c962-c44g (GitHub-reviewed advisory GHSA-w89x-c962-c44g lists affected ranges: Go github.com/cloudreve/Cloudreve/v4 >=0 <4.0.0-20260715070110-bce08f88e9d8) Commands are suggestions: review each one before running it.
Loading voting…