CakePHP: SmtpTransport vulnerable to CRLF header injection
CVE-2026-77634GHSA-2qh5-382h-3jpc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/cakephp 5.3.7, 5.2.14, 5.1.9, 4.6.5, 4.5.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist cakephp/cakephp
- Affected
- >= 4.5.0, < 4.5.12>= 4.6.0, < 4.6.5>= 5.0.0, < 5.1.9>= 5.2.0, < 5.2.14>= 5.3.0, < 5.3.7
- Fixed in
- 5.2.14, 5.1.9, 4.5.12, 5.3.7, 4.6.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2qh5-382h-3jpc lists affected ranges: Packagist cakephp/cakephp >=4.5.0 =4.6.0 =5.0.0 =5.2.0 =5.3.0 <5.3.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-119417: 0.45% estimated exploitation activity in the next 30 days; percentile 39.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
- CVE-2026-77634: 0.54% estimated exploitation activity in the next 30 days; percentile 45.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Custom mail headers added with `Message::setHeaders()` or `addHeaders()` do not have CRLF replaced allowing header injection if user controlled data is added to message headers without stripping CRLF bytes.
Patches 5.3.7, 5.2.14, 5.1.9, 4.6.5, 4.5.12 contain fixes for this issue.
Workarounds You can strip CRLF bytes from email header values before setting header values.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-2qh5-382h-3jpc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2qh5-382h-3jpc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-77634 Advisory: CakePHP: SmtpTransport vulnerable to CRLF header injection IDs: CVE-2026-77634, GHSA-2qh5-382h-3jpc Record: https://patchnext.com/advisories/cve-2026-77634 (revision 3, source checked 31 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cakephp/cakephp 5.3.7, 5.2.14, 5.1.9, 4.6.5, 4.5.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist cakephp/cakephp: affected >= 4.5.0, < 4.5.12; >= 4.6.0, < 4.6.5; >= 5.0.0, < 5.1.9; >= 5.2.0, < 5.2.14; >= 5.3.0, < 5.3.7; fixed in 5.2.14, 5.1.9, 4.5.12, 5.3.7, 4.6.5 ## Suggested inspection (read-only) - Packagist cakephp/cakephp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cakephp/cakephp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2qh5-382h-3jpc (OSV record GHSA-2qh5-382h-3jpc lists affected ranges: Packagist cakephp/cakephp >=4.5.0 =4.6.0 =5.0.0 =5.2.0 =5.3.0 <5.3.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…