Skip to content

← Actionable
High, CVSS 8.8amended

OpenC3 COSMOS: Authenticated OS command injection via the pypi_url setting

CVE-2026-77601GHSA-vp3w-52v9-q57f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openc3 7.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems openc3

    Affected
    >= 5.12.0, <= 7.2.1
    Fixed in
    7.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-77601: 0.63% estimated exploitation activity in the next 30 days; percentile 50.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An authenticated user can execute arbitrary operating system commands on the openc3-cosmos-cmd-tlm-api service. The pypiurl setting is interpolated, unescaped, into a command line that is run through a shell backtick when a plugin is installed. Shell metacharacters in the setting value are executed by /bin/sh. Details The pypiurl value is written through the setsetting API method, reachable over the JSON-RPC endpoint POST /openc3-api/api. In the open-source edition, authorize (openc3/lib/openc3/utilities/authorization.rb) verifies only that the session token is valid and returns the anonymous user; the permission: argument is not enforced, so any authenticated user can write the setting and install a plugin. In the Enterprise edition these actions require the admin role. During plugin install, PluginModel.installphase2 reads the setting and builds the argument string, then runs it through a backtick (openc3/lib/openc3/models/pluginmodel.rb:288): getsetting appends /simple to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vp3w-52v9-q57f

  2. Revision 1 · created ·

    Published from osv record GHSA-vp3w-52v9-q57f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77601

Advisory: OpenC3 COSMOS: Authenticated OS command injection via the `pypi_url` setting
IDs: CVE-2026-77601, GHSA-vp3w-52v9-q57f
Record: https://patchnext.com/advisories/cve-2026-77601 (revision 2, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openc3 7.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems openc3: affected >= 5.12.0, <= 7.2.1; fixed in 7.3.0

## Suggested inspection (read-only)
- RubyGems openc3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openc3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vp3w-52v9-q57f (OSV record GHSA-vp3w-52v9-q57f lists affected ranges: RubyGems openc3 >=5.12.0 <7.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vp3w-52v9-q57f (GitHub-reviewed advisory GHSA-vp3w-52v9-q57f lists affected ranges: RubyGems openc3 >=5.12.0 <=7.2.1)

Commands are suggestions: review each one before running it.

Loading voting…