Skip to content

← Actionable
High, CVSS 8.1amended

Filament: Multi-factor authentication (app) can be bypassed when recovery codes are enabled

CVE-2026-77567GHSA-52xp-w8hr-xv3c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (filament/filament 5.7.0, 4.12.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist filament/filament

    Affected
    >= 4.0.0, < 4.12.0>= 5.0.0, < 5.7.0
    Fixed in
    4.12.0, 5.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-77567: 0.55% estimated exploitation activity in the next 30 days; percentile 46.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw in the challenge handling for app-based multi-factor authentication allows the second factor to be bypassed. This issue does not affect email-based MFA. It also only applies when recovery codes are enabled.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-52xp-w8hr-xv3c

  2. Revision 1 · created ·

    Published from osv record GHSA-52xp-w8hr-xv3c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77567

Advisory: Filament: Multi-factor authentication (app) can be bypassed when recovery codes are enabled
IDs: CVE-2026-77567, GHSA-52xp-w8hr-xv3c
Record: https://patchnext.com/advisories/cve-2026-77567 (revision 2, source checked 26 Oct 2026, 14:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: filament/filament 5.7.0, 4.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist filament/filament: affected >= 4.0.0, < 4.12.0; >= 5.0.0, < 5.7.0; fixed in 4.12.0, 5.7.0

## Suggested inspection (read-only)
- Packagist filament/filament: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on filament/filament.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-52xp-w8hr-xv3c (OSV record GHSA-52xp-w8hr-xv3c lists affected ranges: Packagist filament/filament >=4.0.0 =5.0.0 <5.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-52xp-w8hr-xv3c (GitHub-reviewed advisory GHSA-52xp-w8hr-xv3c lists affected ranges: Packagist filament/filament >=4.0.0 =5.0.0 <5.7.0)

Commands are suggestions: review each one before running it.

Loading voting…