Skip to content

← Actionable
Medium, CVSS 5.3amended

Autobahn Python permessage-deflate bypasses maxMessagePayloadSize after inflation

CVE-2026-77528GHSA-hxp9-w8x3-p566

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (autobahn 26.7.1; crossbar 26.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI autobahn

    Affected
    < 26.7.1
    Fixed in
    26.7.1
  • PyPI crossbar

    Affected
    < 26.7.1
    Fixed in
    26.7.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-77528: 0.52% estimated exploitation activity in the next 30 days; percentile 44.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Autobahn Python enforces maxMessagePayloadSize against the compressed WebSocket frame length before permessage-deflate inflation, then delivers the inflated message to application callbacks without a second size check. A client frame that is only 22 compressed bytes can inflate to 4096 bytes and reach onMessage even when the application configured a 128-byte message limit, defeating the resource boundary the option is meant to provide. Details The permessage-deflate path installs a PerMessageDeflate instance when the server accepts a client offer in src/autobahn/websocket/protocol.py:3371. The common PerMessageDeflateOfferAccept(offer) path leaves maxmessagesize at its default None in src/autobahn/websocket/compressdeflate.py:295, and that value is copied into the compressor object in src/autobahn/websocket/compressdeflate.py:723. When a data frame arrives with RSV1 set, Autobahn marks the message compressed in src/autobahn/websocket/protocol.py:1812, calls…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hxp9-w8x3-p566

  2. Revision 2 · amended ·

    Amended from osv record GHSA-hxp9-w8x3-p566

  3. Revision 1 · created ·

    Published from ghsa record GHSA-hxp9-w8x3-p566

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77528

Advisory: Autobahn Python permessage-deflate bypasses maxMessagePayloadSize after inflation
IDs: CVE-2026-77528, GHSA-hxp9-w8x3-p566
Record: https://patchnext.com/advisories/cve-2026-77528 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: autobahn 26.7.1; crossbar 26.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI autobahn: affected < 26.7.1; fixed in 26.7.1
- PyPI crossbar: affected < 26.7.1; fixed in 26.7.1

## Suggested inspection (read-only)
- `python -m pip show autobahn`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show crossbar`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on autobahn, crossbar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hxp9-w8x3-p566 (GitHub-reviewed advisory GHSA-hxp9-w8x3-p566 lists affected ranges: PyPI autobahn >=0 =0 <26.7.1)
- Verified: https://osv.dev/vulnerability/GHSA-hxp9-w8x3-p566 (OSV record GHSA-hxp9-w8x3-p566 lists affected ranges: PyPI autobahn >=0 =0 <26.7.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…