Skip to content

← Actionable
High, CVSS 7.1amended

Unleash: Missing await on permission check + cross-project IDOR in admin API

CVE-2026-77426GHSA-72h8-wp98-7hch

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (unleash-server 8.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-77426: 0.48% estimated exploitation activity in the next 30 days; percentile 41.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Multiple authorization vulnerabilities in Unleash admin API, including a critical missing await that completely bypasses a permission check. Vulnerability 1: Missing await on Permission Check (HIGH) File: src/lib/features/segment/segment-controller.ts (line 345) POST /api/admin/segments/strategies has permission: NONE at the route level. The handler performs its own check via this.accessService.hasPermission(), but omits the await keyword. Since hasPermission() is async (returns Promise<boolean), the variable always receives a truthy Promise object. The if (!hasFeatureStrategyPermission) check never triggers. Impact: Any authenticated user can modify segment assignments on ANY strategy across ALL projects. Fix: Add await: const hasFeatureStrategyPermission = await this.accessService.hasPermission(...) Vulnerability 2: Cross-Project Variant Read (MEDIUM) File: src/lib/routes/admin-api/project/variants.ts (line 213-223) GET…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-72h8-wp98-7hch

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-72h8-wp98-7hch

  4. Revision 1 · created ·

    Published from ghsa record GHSA-72h8-wp98-7hch

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77426

Advisory: Unleash: Missing await on permission check + cross-project IDOR in admin API
IDs: CVE-2026-77426, GHSA-72h8-wp98-7hch
Record: https://patchnext.com/advisories/cve-2026-77426 (revision 4, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: unleash-server 8.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm unleash-server: affected < 8.0.3; fixed in 8.0.3

## Suggested inspection (read-only)
- `npm ls unleash-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on unleash-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-72h8-wp98-7hch (GitHub-reviewed advisory GHSA-72h8-wp98-7hch lists affected ranges: npm unleash-server >=0 <8.0.3)
- Verified: https://osv.dev/vulnerability/GHSA-72h8-wp98-7hch (OSV record GHSA-72h8-wp98-7hch lists affected ranges: npm unleash-server >=0 <8.0.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…