Skip to content

← Actionable
Critical, CVSS 9.3amended

JSONata: Arbitrary Code Execution via crafted JSONata expressions

CVE-2026-77413GHSA-8gq3-vp5j-2grp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsonata 2.2.0, 1.8.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm jsonata

    Affected
    <= 1.8.7>= 2.0.0, < 2.2.0
    Fixed in
    2.2.0, 1.8.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-77413: 0.72% estimated exploitation activity in the next 30 days; percentile 53.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Before JSONata 2.2.0 and 1.8.8 it was possible to execute arbitrary code with crafted expressions, due to a missing hasOwnProperty check in the lookup function: https://github.com/jsonata-js/jsonata/blob/f9632e01e6e67d4f9f00593f9795420cb4b57f48/src/functions.js#L1686-L1705 This was fixed with https://github.com/jsonata-js/jsonata/pull/794, which is included in the 2.2.0 release, and ported in the 1.8.8 release. PoC

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-8gq3-vp5j-2grp

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-8gq3-vp5j-2grp

  4. Revision 1 · created ·

    Published from ghsa record GHSA-8gq3-vp5j-2grp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77413

Advisory: JSONata: Arbitrary Code Execution via crafted JSONata expressions
IDs: CVE-2026-77413, GHSA-8gq3-vp5j-2grp
Record: https://patchnext.com/advisories/cve-2026-77413 (revision 4, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jsonata 2.2.0, 1.8.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jsonata: affected <= 1.8.7; >= 2.0.0, < 2.2.0; fixed in 2.2.0, 1.8.8

## Suggested inspection (read-only)
- `npm ls jsonata --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jsonata.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8gq3-vp5j-2grp (GitHub-reviewed advisory GHSA-8gq3-vp5j-2grp lists affected ranges: npm jsonata >=0 =2.0.0 <2.2.0)
- Verified: https://osv.dev/vulnerability/GHSA-8gq3-vp5j-2grp (OSV record GHSA-8gq3-vp5j-2grp lists affected ranges: npm jsonata >=0 =2.0.0 <2.2.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…