RabbitMQ amqp091-go: Denial of Service via Malicious Field Length in AMQP Client
CVE-2026-77412GHSA-4v58-74mf-rjx3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rabbitmq/amqp091-go 1.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/rabbitmq/amqp091-go
- Affected
- < 1.13.0
- Fixed in
- 1.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4v58-74mf-rjx3 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6494 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4v58-74mf-rjx3 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H · score source
- EPSS
- CVE-2026-77412: 0.52% estimated exploitation activity in the next 30 days; percentile 44.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A vulnerability in the readField function allows a malicious or compromised AMQP server to trigger an unhandled runtime panic in the client application, leading to an immediate crash of the entire process. Details When parsing incoming AMQP frames, the readField function processes byte-array fields (type tag 'x') by reading a 32-bit big-endian integer to determine the length of the data payload. If a server transmits a length value of 0xFFFFFFFF, it is interpreted by the client as a signed 32-bit integer with a value of -1. Passing a negative integer to Go's built-in make() function for slice allocation triggers an unrecoverable runtime panic (panic: len out of range). Because the reader goroutine handles network I/O without an explicit recover() wrapper, this panic propagates up to the runtime root, abruptly terminating the host application. Attack Vector / Exploitation Scenario An attacker capable of spoofing, compromising, or controlling an AMQP broker can exploit this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-4v58-74mf-rjx3
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6494
- Revision 1 · created ·
Published from osv record GHSA-4v58-74mf-rjx3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-77412 Advisory: RabbitMQ amqp091-go: Denial of Service via Malicious Field Length in AMQP Client IDs: CVE-2026-77412, GHSA-4v58-74mf-rjx3 Record: https://patchnext.com/advisories/cve-2026-77412 (revision 4, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rabbitmq/amqp091-go 1.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rabbitmq/amqp091-go: affected < 1.13.0; fixed in 1.13.0 ## Suggested inspection (read-only) - Go github.com/rabbitmq/amqp091-go: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rabbitmq/amqp091-go. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4v58-74mf-rjx3 (OSV record GHSA-4v58-74mf-rjx3 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6494 (OSV record GO-2026-6494 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4v58-74mf-rjx3 (GitHub-reviewed advisory GHSA-4v58-74mf-rjx3 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0) Commands are suggestions: review each one before running it.
Loading voting…