RabbitMQ amqp091-go: Protocol Desynchronization and Frame Injection via Integer Overflow in readLongstr
CVE-2026-77411GHSA-c5pq-fr2g-9jpf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rabbitmq/amqp091-go 1.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/rabbitmq/amqp091-go
- Affected
- < 1.13.0
- Fixed in
- 1.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c5pq-fr2g-9jpf lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6496 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c5pq-fr2g-9jpf lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-77411: 0.52% estimated exploitation activity in the next 30 days; percentile 44.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A critical stream desynchronization vulnerability has been identified in the AMQP wire-protocol parser. When parsing a long string (readLongstr) within a table field, providing a length that exceeds the maximum signed 32-bit integer (2^31 - 1, or roughly 2.1 GiB) triggers an improper error-handling condition. The parser abruptly aborts the read and returns a success status ("",nil) without consuming the specified bytes from the underlying network buffer. This causes all subsequent read operations to become misaligned. The parser interprets arbitrary offsets within the remaining payload bytes as valid AMQP frame headers, leading to potential Remote Code Execution (RCE), data injection, or complete connection hijacking. Vulnerability Details The vulnerability exists within the bounds-checking logic of the readLongstr function: When length evaluates to a value greater than 0x7FFFFFFF: 1. The function executes a silent return statement. 2. Because Go utilizes named or zero-value…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-c5pq-fr2g-9jpf
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6496
- Revision 1 · created ·
Published from osv record GHSA-c5pq-fr2g-9jpf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-77411 Advisory: RabbitMQ amqp091-go: Protocol Desynchronization and Frame Injection via Integer Overflow in readLongstr IDs: CVE-2026-77411, GHSA-c5pq-fr2g-9jpf Record: https://patchnext.com/advisories/cve-2026-77411 (revision 4, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rabbitmq/amqp091-go 1.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rabbitmq/amqp091-go: affected < 1.13.0; fixed in 1.13.0 ## Suggested inspection (read-only) - Go github.com/rabbitmq/amqp091-go: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rabbitmq/amqp091-go. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c5pq-fr2g-9jpf (OSV record GHSA-c5pq-fr2g-9jpf lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6496 (OSV record GO-2026-6496 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)) - Verified: https://github.com/advisories/GHSA-c5pq-fr2g-9jpf (GitHub-reviewed advisory GHSA-c5pq-fr2g-9jpf lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0) Commands are suggestions: review each one before running it.
Loading voting…