Skip to content

← Actionable
High, CVSS 7.0amended

RabbitMQ amqp091-go: Plaintext Credential Exposure via Exported PLAIN Authentication Struct Fields

CVE-2026-77407GHSA-27gv-rfvv-22mv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rabbitmq/amqp091-go 1.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.0 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:L/SA:L · score source
EPSS
  • CVE-2026-77407: 0.13% estimated exploitation activity in the next 30 days; percentile 2.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An information disclosure vulnerability exists in the AMQP client implementation's authentication handling configuration. Following a successful connection handshake, the Connection.Config.SASL field stores the Authentication implementation state used to establish the session. For standard PLAIN authentication, this state utilizes the PlainAuth struct, which defines both Username and Password as publicly exported, plaintext string fields. Because this sensitive data is retained permanently in-memory within an exported field structure, any peripheral code, internal package, reflective logger, dependency, or automated debugging utility with access to the core Connection object can read and expose the raw credentials. --- Vulnerability Details Mechanism The vulnerability stems from the structural design of the configuration storage used during and after the AMQP handshake: When an application initializes a connection, the PlainAuth object is deeply nested inside the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-27gv-rfvv-22mv

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6491

  4. Revision 1 · created ·

    Published from osv record GHSA-27gv-rfvv-22mv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77407

Advisory: RabbitMQ amqp091-go: Plaintext Credential Exposure via Exported PLAIN Authentication Struct Fields
IDs: CVE-2026-77407, GHSA-27gv-rfvv-22mv
Record: https://patchnext.com/advisories/cve-2026-77407 (revision 4, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rabbitmq/amqp091-go 1.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rabbitmq/amqp091-go: affected < 1.13.0; fixed in 1.13.0

## Suggested inspection (read-only)
- Go github.com/rabbitmq/amqp091-go: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rabbitmq/amqp091-go.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-27gv-rfvv-22mv (OSV record GHSA-27gv-rfvv-22mv lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6491 (OSV record GO-2026-6491 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-27gv-rfvv-22mv (GitHub-reviewed advisory GHSA-27gv-rfvv-22mv lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0)

Commands are suggestions: review each one before running it.

Loading voting…