RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser
CVE-2026-77405GHSA-33mj-cw25-m34h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rabbitmq/amqp091-go 1.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/rabbitmq/amqp091-go
- Affected
- < 1.13.0
- Fixed in
- 1.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-33mj-cw25-m34h lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6492 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-33mj-cw25-m34h lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:N · score source
- EPSS
- CVE-2026-77405: 0.28% estimated exploitation activity in the next 30 days; percentile 20.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A structural security weakness exists in the AMQP client's TLS configuration generator (tlsConfigFromURI). When constructing a tls.Config object from an amqps:// connection URI, the library initializes the structure without explicitly defining the MinVersion field. While modern versions of the Go compiler toolchain (Go 1.18+) default the implicit minimum version to TLS 1.2, this security posture relies entirely on an implicit toolchain dependency. If the library is compiled using legacy Go toolchains (Go < 1.18), or if a future toolchain introduces fallback behavior, the client could silently negotiate obsolete and insecure TLS 1.0 or TLS 1.1 protocols during connection handshakes with a compromised or malicious AMQP broker. --- Vulnerability Details Mechanism The vulnerability lies in the lack of an explicit safety floor when assigning configurations inside the URI component: In the Go standard library (crypto/tls), leaving MinVersion: 0 instructs the runtime to choose the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-33mj-cw25-m34h
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6492
- Revision 1 · created ·
Published from osv record GHSA-33mj-cw25-m34h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-77405 Advisory: RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser IDs: CVE-2026-77405, GHSA-33mj-cw25-m34h Record: https://patchnext.com/advisories/cve-2026-77405 (revision 4, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rabbitmq/amqp091-go 1.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rabbitmq/amqp091-go: affected < 1.13.0; fixed in 1.13.0 ## Suggested inspection (read-only) - Go github.com/rabbitmq/amqp091-go: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rabbitmq/amqp091-go. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-33mj-cw25-m34h (OSV record GHSA-33mj-cw25-m34h lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6492 (OSV record GO-2026-6492 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed)) - Verified: https://github.com/advisories/GHSA-33mj-cw25-m34h (GitHub-reviewed advisory GHSA-33mj-cw25-m34h lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0) Commands are suggestions: review each one before running it.
Loading voting…