Skip to content

← Actionable
High, CVSS 8.7amended

RabbitMQ amqp091-go: Connection Configuration Overwrite via Unsanitized TLS Path Parameter Injection

CVE-2026-77404GHSA-465g-fh3v-9jw4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rabbitmq/amqp091-go 1.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:L · score source
EPSS
  • CVE-2026-77404: 0.10% estimated exploitation activity in the next 30 days; percentile 1.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A query parameter injection vulnerability exists in the AMQP client's connection URI formatting logic. When generating or parsing connection URIs, TLS-related filesystem paths (such as certificates or keys) are appended directly to the URI's query string using string concatenation rather than secure URL encoding via functions like url.QueryEscape. If an application handles a TLS file path containing special character delimiters (such as & or =), these characters are interpreted as parameter separators by the URI parser. If the resulting URI.String() output is subsequently re-parsed via ParseURI, the injected fields can silently overwrite or hijack critical configuration parameters, forcing the client to use arbitrary connection settings or alternate TLS files. --- Vulnerability Details Mechanism The vulnerability lies within the lack of proper escaping when compiling connection string components into a raw URL format: Because certPath and keyPath are not passed through…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-465g-fh3v-9jw4

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6493

  4. Revision 1 · created ·

    Published from osv record GHSA-465g-fh3v-9jw4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77404

Advisory: RabbitMQ amqp091-go: Connection Configuration Overwrite via Unsanitized TLS Path Parameter Injection
IDs: CVE-2026-77404, GHSA-465g-fh3v-9jw4
Record: https://patchnext.com/advisories/cve-2026-77404 (revision 4, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rabbitmq/amqp091-go 1.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rabbitmq/amqp091-go: affected < 1.13.0; fixed in 1.13.0

## Suggested inspection (read-only)
- Go github.com/rabbitmq/amqp091-go: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rabbitmq/amqp091-go.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-465g-fh3v-9jw4 (OSV record GHSA-465g-fh3v-9jw4 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6493 (OSV record GO-2026-6493 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-465g-fh3v-9jw4 (GitHub-reviewed advisory GHSA-465g-fh3v-9jw4 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0)

Commands are suggestions: review each one before running it.

Loading voting…