Skip to content

← Actionable
High, CVSS 8.9amended

RabbitMQ amqp091-go: Denial of Service via Sub-Spec Frame Size Negotiation

CVE-2026-77403GHSA-xwwf-m8fg-p9q2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rabbitmq/amqp091-go 1.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H · score source
EPSS
  • CVE-2026-77403: 0.52% estimated exploitation activity in the next 30 days; percentile 44.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Denial of Service (DoS) vulnerability exists in the AMQP client's connection negotiation logic. The AMQP specification explicitly mandates a strict minimum frame size of 4096 bytes to prevent pathological packet fragmentation. While the library defines a frameMinSize = 4096 constant, the connection negotiation loop fails to enforce this boundary, blindly accepting whatever maximum frame size (FrameMax) the server advertises during the handshake. If a client connects to a malicious or compromised AMQP broker that advertises an extremely low FrameMax (such as 1 byte), the negotiation succeeds. Consequently, every subsequent message transmission is forced to splinter into thousands or millions of single-byte frames, causing massive CPU overhead, thread contention, and a near-instantaneous application freeze. --- Vulnerability Details Mechanism During the connection establishment phase, the client and server negotiate connection parameters—including maximum channel count,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-xwwf-m8fg-p9q2

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6503

  4. Revision 1 · created ·

    Published from osv record GHSA-xwwf-m8fg-p9q2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77403

Advisory: RabbitMQ amqp091-go: Denial of Service via Sub-Spec Frame Size Negotiation
IDs: CVE-2026-77403, GHSA-xwwf-m8fg-p9q2
Record: https://patchnext.com/advisories/cve-2026-77403 (revision 4, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rabbitmq/amqp091-go 1.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rabbitmq/amqp091-go: affected < 1.13.0; fixed in 1.13.0

## Suggested inspection (read-only)
- Go github.com/rabbitmq/amqp091-go: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rabbitmq/amqp091-go.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xwwf-m8fg-p9q2 (OSV record GHSA-xwwf-m8fg-p9q2 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6503 (OSV record GO-2026-6503 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-xwwf-m8fg-p9q2 (GitHub-reviewed advisory GHSA-xwwf-m8fg-p9q2 lists affected ranges: Go github.com/rabbitmq/amqp091-go >=0 <1.13.0)

Commands are suggestions: review each one before running it.

Loading voting…