Skip to content

← Actionable
High, CVSS 7.6amended

OpenC3 COSMOS: Stored, cross-user XSS via Telemetry screen BUTTON widget

CVE-2026-77394GHSA-gvf2-2rh5-mpgf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openc3/vue-common 7.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-77394: 0.42% estimated exploitation activity in the next 30 days; percentile 36.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A user who can save a telemetry screen (permission systemset) can embed JavaScript in a screen BUTTON widget. The BUTTON widget eval()s the stored button text in the browser when the button is activated, and screens are shared content rendered to other users in the scope. As a result, an attacker's stored JavaScript executes in a different operator's authenticated session — a stored, cross-user XSS (not self-XSS). The payload runs in the COSMOS origin and can read localStorage.openc3Token (the victim's session token), enabling session/account takeover and, via the victim's privileges, a path to server-side code execution through the Script Runner. The site's Content-Security-Policy permits 'unsafe-inline'/'unsafe-eval' (see "Contributing factor"), so the injected script runs unimpeded. - Product: OpenC3 COSMOS (Core; likely Enterprise — see scoping note) - Affected version: confirmed 7.2.0 (latest, tested 2026-06-25); the code path is present on main. Lower bound for…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gvf2-2rh5-mpgf

  2. Revision 2 · amended ·

    Amended from osv record GHSA-gvf2-2rh5-mpgf

  3. Revision 1 · created ·

    Published from ghsa record GHSA-gvf2-2rh5-mpgf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77394

Advisory: OpenC3 COSMOS: Stored, cross-user XSS via Telemetry screen BUTTON widget
IDs: CVE-2026-77394, GHSA-gvf2-2rh5-mpgf
Record: https://patchnext.com/advisories/cve-2026-77394 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @openc3/vue-common 7.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @openc3/vue-common: affected >= 5.0.6, <= 7.2.1; fixed in 7.3.0

## Suggested inspection (read-only)
- `npm ls @openc3/vue-common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @openc3/vue-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gvf2-2rh5-mpgf (GitHub-reviewed advisory GHSA-gvf2-2rh5-mpgf lists affected ranges: npm @openc3/vue-common >=5.0.6 <=7.2.1)
- Verified: https://osv.dev/vulnerability/GHSA-gvf2-2rh5-mpgf (OSV record GHSA-gvf2-2rh5-mpgf lists affected ranges: npm @openc3/vue-common >=5.0.6 <7.3.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…