Skip to content

← Actionable
Medium, CVSS 4.0amended

geopy: Regular Expression Denial of Service (ReDoS) in geopy.Point

CVE-2026-77387GHSA-mhvh-fq92-pfmr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (geopy 2.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI geopy

    Affected
    <= 2.4.1
    Fixed in
    2.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.0 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-77387: 0.20% estimated exploitation activity in the next 30 days; percentile 10.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact geopy.Point and Point.fromstring() may take excessive CPU time when parsing long, malformed coordinate strings due to inefficient regular-expression behavior. The numeric Point constructor is not affected. Geocoders' reverse methods called with string inputs exercise the vulnerable path. Applications are affected when they pass attacker-controlled strings to these APIs without an appropriate length limit. Repeated requests may cause denial of service. Patches Fixed in geopy 2.5.0 by rejecting overly long (over 256 characters) coordinate strings before parsing. Workarounds Limit coordinate strings to a reasonable maximum length, such as 256 characters, before passing them to geopy.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mhvh-fq92-pfmr

  2. Revision 2 · amended ·

    Amended from osv record GHSA-mhvh-fq92-pfmr

  3. Revision 1 · created ·

    Published from ghsa record GHSA-mhvh-fq92-pfmr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77387

Advisory: geopy: Regular Expression Denial of Service (ReDoS) in geopy.Point
IDs: CVE-2026-77387, GHSA-mhvh-fq92-pfmr
Record: https://patchnext.com/advisories/cve-2026-77387 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: geopy 2.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI geopy: affected <= 2.4.1; fixed in 2.5.0

## Suggested inspection (read-only)
- `python -m pip show geopy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on geopy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mhvh-fq92-pfmr (GitHub-reviewed advisory GHSA-mhvh-fq92-pfmr lists affected ranges: PyPI geopy >=0 <=2.4.1)
- Verified: https://osv.dev/vulnerability/GHSA-mhvh-fq92-pfmr (OSV record GHSA-mhvh-fq92-pfmr lists affected ranges: PyPI geopy >=0 <2.5.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…