Skip to content

← Actionable
Critical, CVSS 9.9amended

obsidian-tc tokens can access arbitrary configured vaults

CVE-2026-77366GHSA-84c9-qqpq-2pq5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (obsidian-tc 1.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-77366: 0.31% estimated exploitation activity in the next 30 days; percentile 23.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Tool dispatch did not check the caller-supplied input.vault against the caller's bound vault (ctx.vaultId); the folder ACL was a single global instance and the JWT carried no vault claim. As a result, any valid token could read, write, or delete any configured vault by passing input.vault, defeating multi-tenant isolation across ~90 tool sites. (resources/read was the only surface that already guarded this.) Patches Fixed in 1.3.1 (the fix was developed on the v1.3.0 tag, which never published to npm; 1.3.1 is the first published release with the fix). Upgrade to = 1.3.1. Workarounds Run a single vault per server process, or isolate each tenant on a separate process/credential. Fix A central input.vault === ctx.vaultId guard was added in dispatch before the scope check.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-84c9-qqpq-2pq5

  2. Revision 2 · amended ·

    Amended from osv record GHSA-84c9-qqpq-2pq5

  3. Revision 1 · created ·

    Published from ghsa record GHSA-84c9-qqpq-2pq5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77366

Advisory: obsidian-tc tokens can access arbitrary configured vaults
IDs: CVE-2026-77366, GHSA-84c9-qqpq-2pq5
Record: https://patchnext.com/advisories/cve-2026-77366 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: obsidian-tc 1.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm obsidian-tc: affected < 1.3.1; fixed in 1.3.1

## Suggested inspection (read-only)
- `npm ls obsidian-tc --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on obsidian-tc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-84c9-qqpq-2pq5 (GitHub-reviewed advisory GHSA-84c9-qqpq-2pq5 lists affected ranges: npm obsidian-tc >=0 <1.3.1)
- Verified: https://osv.dev/vulnerability/GHSA-84c9-qqpq-2pq5 (OSV record GHSA-84c9-qqpq-2pq5 lists affected ranges: npm obsidian-tc >=0 <1.3.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…