Skip to content

← Actionable
Medium, CVSS 6.5amended

obsidian-tc: Default folder ACL is fail-open; .obsidian plugin secrets are readable by default

CVE-2026-77364GHSA-cvp8-vvgf-69q4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (obsidian-tc 1.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-77364: 0.24% estimated exploitation activity in the next 30 days; percentile 15.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact With a default configuration, an undefined readPaths/writePaths meant allow-all, the strictReadDefault flag was inert, and the .obsidian/.git/.trash control directories were denied only during enumeration — not on the direct request path. A caller could read .obsidian/plugins//data.json, exfiltrating plugin API keys and Obsidian Sync passwords (live-reproduced), as well as any other in-vault file by path. Patches Fixed in 1.3.1. Upgrade to = 1.3.1. The default now denies .obsidian/.git/.trash on read/write/delete and honors strictReadDefault on the request path. Workarounds Set an explicit readPaths/writePaths whitelist that excludes the control directories.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cvp8-vvgf-69q4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-cvp8-vvgf-69q4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-cvp8-vvgf-69q4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77364

Advisory: obsidian-tc: Default folder ACL is fail-open; .obsidian plugin secrets are readable by default
IDs: CVE-2026-77364, GHSA-cvp8-vvgf-69q4
Record: https://patchnext.com/advisories/cve-2026-77364 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: obsidian-tc 1.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm obsidian-tc: affected < 1.3.1; fixed in 1.3.1

## Suggested inspection (read-only)
- `npm ls obsidian-tc --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on obsidian-tc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cvp8-vvgf-69q4 (GitHub-reviewed advisory GHSA-cvp8-vvgf-69q4 lists affected ranges: npm obsidian-tc >=0 <1.3.1)
- Verified: https://osv.dev/vulnerability/GHSA-cvp8-vvgf-69q4 (OSV record GHSA-cvp8-vvgf-69q4 lists affected ranges: npm obsidian-tc >=0 <1.3.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…