Skip to content

← Actionable
Medium, CVSS 4.3amended

obsidian-tc Bridge tools leak denied-note data via unfiltered sibling fields

CVE-2026-77362GHSA-43r2-c7g8-prc8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (obsidian-tc 1.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-77362: 0.20% estimated exploitation activity in the next 30 days; percentile 9.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Bridge tool results filtered only the items array against the read ACL and passed sibling fields through unfiltered: tasksfilter emitted groups whose counts reflected denied notes, makemdquery returned ...result siblings, and listtemplates enumerated Templater template paths and parsed user-function bodies with no read-whitelist gate. A caller could infer or read data from notes outside its read ACL. Patches Fixed in 1.3.1. Upgrade to = 1.3.1. All path-attributable fields are now scrubbed or fail-closed, and listtemplates is gated on the read whitelist. Workarounds Disable the affected bridge tools (tasksfilter, makemdquery, listtemplates) via tool visibility.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-43r2-c7g8-prc8

  2. Revision 2 · amended ·

    Amended from osv record GHSA-43r2-c7g8-prc8

  3. Revision 1 · created ·

    Published from ghsa record GHSA-43r2-c7g8-prc8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77362

Advisory: obsidian-tc Bridge tools leak denied-note data via unfiltered sibling fields
IDs: CVE-2026-77362, GHSA-43r2-c7g8-prc8
Record: https://patchnext.com/advisories/cve-2026-77362 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: obsidian-tc 1.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm obsidian-tc: affected < 1.3.1; fixed in 1.3.1

## Suggested inspection (read-only)
- `npm ls obsidian-tc --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on obsidian-tc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-43r2-c7g8-prc8 (GitHub-reviewed advisory GHSA-43r2-c7g8-prc8 lists affected ranges: npm obsidian-tc >=0 <1.3.1)
- Verified: https://osv.dev/vulnerability/GHSA-43r2-c7g8-prc8 (OSV record GHSA-43r2-c7g8-prc8 lists affected ranges: npm obsidian-tc >=0 <1.3.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…