Skip to content

← Actionable
Medium, CVSS 6.3amended

oRPC: Vary Header Injection in CORS Plugin leading to potential Cache/CORS Bypass

CVE-2026-77360GHSA-j9v4-rhgr-4m5f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@orpc/server 1.14.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-77360: 0.54% estimated exploitation activity in the next 30 days; percentile 45.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A flaw in the CORS plugin allowed the incoming request's Vary header to be reflected into the response, letting a client influence a header that should be controlled solely by the server. Details The CORS plugin previously copied the request's Vary header directly onto the response instead of treating Vary as a response-only header. Because Vary tells downstream caches and proxies how to key their cached responses, this allowed a client to inject arbitrary values into the response's Vary header, potentially distorting cache-key behavior in shared caches/CDNs sitting in front of an oRPC server and leading to inconsistent CORS enforcement for other clients. Practical impact is limited to deployments where a shared cache or reverse proxy keys on the Vary header; the real-world effect depends on the caching layer's configuration. Impact May cause cache key pollution and inconsistent CORS enforcement in setups that rely on shared/edge caches keying on Vary. No direct…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-j9v4-rhgr-4m5f

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-j9v4-rhgr-4m5f

  4. Revision 1 · created ·

    Published from ghsa record GHSA-j9v4-rhgr-4m5f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77360

Advisory: oRPC: Vary Header Injection in CORS Plugin leading to potential Cache/CORS Bypass
IDs: CVE-2026-77360, GHSA-j9v4-rhgr-4m5f
Record: https://patchnext.com/advisories/cve-2026-77360 (revision 4, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @orpc/server 1.14.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @orpc/server: affected <= 1.14.7; fixed in 1.14.8

## Suggested inspection (read-only)
- `npm ls @orpc/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @orpc/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j9v4-rhgr-4m5f (GitHub-reviewed advisory GHSA-j9v4-rhgr-4m5f lists affected ranges: npm @orpc/server >=0 <=1.14.7)
- Verified: https://osv.dev/vulnerability/GHSA-j9v4-rhgr-4m5f (OSV record GHSA-j9v4-rhgr-4m5f lists affected ranges: npm @orpc/server >=0 <1.14.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…