kin-openapi has uncontrolled resource consumption in openapi3filter deepObject query parameter decoding
CVE-2026-77354GHSA-xhj3-7xw9-vr34
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/getkin/kin-openapi 0.142.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/getkin/kin-openapi
- Affected
- >= 0.124.0, < 0.142.0
- Fixed in
- 0.142.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xhj3-7xw9-vr34 lists affected ranges: Go github.com/getkin/kin-openapi >=0.124.0 <0.142.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6275 lists affected ranges: Go github.com/getkin/kin-openapi >=0.124.0 <0.142.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xhj3-7xw9-vr34 lists affected ranges: Go github.com/getkin/kin-openapi >=0.124.0 <0.142.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-77354: 0.52% estimated exploitation activity in the next 30 days; percentile 44.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An uncontrolled resource consumption vulnerability in openapi3filter lets any unauthenticated client force multi-gigabyte heap allocation with a single, tiny HTTP request. When a spec declares a deepObject-style query parameter whose schema contains an array (a normal, documented pattern), the decoder reconstructs the array by reading the largest attacker-supplied index and allocating one slot for every position from 0 up to that index — before schema validation (including maxItems) ever runs. A request as small as 24 bytes (?param[items][50000000]=x) drives heap allocation to ~6.1 GiB, reliably triggering an OOM kill / restart loop on memory-constrained services. Details The OpenAPI style: deepObject serialization lets clients express arrays in the query string using bracket notation, e.g. param[items][0]=a¶m[items][1]=b. The decoder first collects these into an intermediate map[string]any keyed by the string of the index, then converts that sparse map into a real []any…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-xhj3-7xw9-vr34
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6275
- Revision 1 · created ·
Published from osv record GHSA-xhj3-7xw9-vr34
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-77354 Advisory: kin-openapi has uncontrolled resource consumption in openapi3filter deepObject query parameter decoding IDs: CVE-2026-77354, GHSA-xhj3-7xw9-vr34 Record: https://patchnext.com/advisories/cve-2026-77354 (revision 4, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/getkin/kin-openapi 0.142.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/getkin/kin-openapi: affected >= 0.124.0, < 0.142.0; fixed in 0.142.0 ## Suggested inspection (read-only) - Go github.com/getkin/kin-openapi: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/getkin/kin-openapi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xhj3-7xw9-vr34 (OSV record GHSA-xhj3-7xw9-vr34 lists affected ranges: Go github.com/getkin/kin-openapi >=0.124.0 <0.142.0 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6275 (OSV record GO-2026-6275 lists affected ranges: Go github.com/getkin/kin-openapi >=0.124.0 <0.142.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xhj3-7xw9-vr34 (GitHub-reviewed advisory GHSA-xhj3-7xw9-vr34 lists affected ranges: Go github.com/getkin/kin-openapi >=0.124.0 <0.142.0) Commands are suggestions: review each one before running it.
Loading voting…