GoBGP has an Improper Resource Shutdown or Release
CVE-2026-7734GHSA-vm3g-8xwv-mxfp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/osrg/gobgp/v4 4.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 4.4.0
- Fixed in
- 4.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vm3g-8xwv-mxfp lists affected ranges: Go github.com/osrg/gobgp/v4 >=0 <4.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-7734: 0.46% estimated exploitation activity in the next 30 days; percentile 40.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability has been found in osrg GoBGP up to 4.3.0. This impacts the function SRv6L3ServiceAttribute.DecodeFromBytes of the file pkg/packet/bgp/prefixsid.go of the component SRv6 L3 Service. Such manipulation of the argument data leads to denial of service. The attack may be performed from remote. Upgrading to version 4.4.0 will fix this issue. The name of the patch is f9f7b55ec258e514be0264871fa645a2c3edad11. Users should upgrade the affected component.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vm3g-8xwv-mxfp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-7734 Advisory: GoBGP has an Improper Resource Shutdown or Release IDs: CVE-2026-7734, GHSA-vm3g-8xwv-mxfp Record: https://patchnext.com/advisories/cve-2026-7734 (revision 1, source checked 26 Oct 2026, 15:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/osrg/gobgp/v4 4.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/osrg/gobgp/v4: affected < 4.4.0; fixed in 4.4.0 ## Suggested inspection (read-only) - Go github.com/osrg/gobgp/v4: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/osrg/gobgp/v4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vm3g-8xwv-mxfp (GitHub-reviewed advisory GHSA-vm3g-8xwv-mxfp lists affected ranges: Go github.com/osrg/gobgp/v4 >=0 <4.4.0) Commands are suggestions: review each one before running it.
Loading voting…