Skip to content

← Actionable
Medium, CVSS 5.4amended

MCP Atlassian: Reflected XSS in OAuth Setup Callback Handler

CVE-2026-77272GHSA-g2r2-3j32-j27x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-atlassian 0.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-77272: 0.26% estimated exploitation activity in the next 30 days; percentile 18.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OAuth 2.0 setup wizard's local callback HTTP server reflects the error query parameter directly into an HTML response without any sanitization or encoding. An attacker can craft a malicious callback URL containing JavaScript in the error parameter that executes in the victim's browser when the setup wizard is running. The server binds to all network interfaces (0.0.0.0), making it accessible from the local network rather than just localhost. Details The vulnerability exists in the CallbackHandler class in src/mcpatlassian/utils/oauthsetup.py. Step 1 -- Attacker-controlled input enters unsanitized: At line 63-66, the error query parameter from the URL is read and interpolated into a message string without HTML escaping: Step 2 -- Unsanitized input is injected into HTML: At line 124-125 in sendresponse, the message variable (containing the unescaped attacker input) is injected directly into the HTML template via f-string interpolation: Step 3 -- Server listens on all…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g2r2-3j32-j27x

  2. Revision 2 · amended ·

    Amended from osv record GHSA-g2r2-3j32-j27x

  3. Revision 1 · created ·

    Published from ghsa record GHSA-g2r2-3j32-j27x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77272

Advisory: MCP Atlassian: Reflected XSS in OAuth Setup Callback Handler
IDs: CVE-2026-77272, GHSA-g2r2-3j32-j27x
Record: https://patchnext.com/advisories/cve-2026-77272 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-atlassian 0.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp-atlassian: affected < 0.22.0; fixed in 0.22.0

## Suggested inspection (read-only)
- `python -m pip show mcp-atlassian`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-atlassian.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g2r2-3j32-j27x (GitHub-reviewed advisory GHSA-g2r2-3j32-j27x lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0)
- Verified: https://osv.dev/vulnerability/GHSA-g2r2-3j32-j27x (OSV record GHSA-g2r2-3j32-j27x lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…