MCP Atlassian: Incomplete path traversal fix allows intra-CWD module overwrite and RCE (bypass of GHSA-xjgw-4wvw-rgm4)
CVE-2026-77271GHSA-6vmq-24h2-pj7j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-atlassian 0.22.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mcp-atlassian
- Affected
- < 0.22.0
- Fixed in
- 0.22.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6vmq-24h2-pj7j lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6vmq-24h2-pj7j lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2026-77271: 0.60% estimated exploitation activity in the next 30 days; percentile 48.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The path traversal fix introduced in v0.17.0 (GHSA-xjgw-4wvw-rgm4) is incomplete. validatesafepath() is called without an explicit basedir, defaulting to os.getcwd(). In standard container deployments the process CWD is the application directory (e.g. /app), so paths within that directory, including the application's own Python source modules, pass validation without raising an exception. An attacker can overwrite a module file and achieve remote code execution on the next process restart. Versions = 0.17.0 are not fully patched as stated in the original advisory. Confirmed on v0.21.0 (latest). Details src/mcpatlassian/utils/io.py — validatesafepath() defaults to CWD when no basedir is supplied: Both call sites in src/mcpatlassian/confluence/attachments.py omit basedir: When the process CWD is /app, any path under /app satisfies isrelativeto(CWD) and passes the guard, including all Python source modules: PoC Prerequisites: same as GHSA-xjgw-4wvw-rgm4 — Confluence credentials…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-6vmq-24h2-pj7j
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-6vmq-24h2-pj7j
- Revision 1 · created ·
Published from ghsa record GHSA-6vmq-24h2-pj7j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-77271 Advisory: MCP Atlassian: Incomplete path traversal fix allows intra-CWD module overwrite and RCE (bypass of GHSA-xjgw-4wvw-rgm4) IDs: CVE-2026-77271, GHSA-6vmq-24h2-pj7j Record: https://patchnext.com/advisories/cve-2026-77271 (revision 4, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mcp-atlassian 0.22.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mcp-atlassian: affected < 0.22.0; fixed in 0.22.0 ## Suggested inspection (read-only) - `python -m pip show mcp-atlassian`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mcp-atlassian. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6vmq-24h2-pj7j (GitHub-reviewed advisory GHSA-6vmq-24h2-pj7j lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0) - Verified: https://osv.dev/vulnerability/GHSA-6vmq-24h2-pj7j (OSV record GHSA-6vmq-24h2-pj7j lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…