Skip to content

← Actionable
Medium, CVSS 6.5amended

MCP Atlassian: Path traversal in upload_attachment allows arbitrary file read and exfiltration via MCP tool call

CVE-2026-77266GHSA-mfv2-4wvm-9pgp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-atlassian 0.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-77266: 0.50% estimated exploitation activity in the next 30 days; percentile 42.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The uploadattachment functions in both the Jira and Confluence modules accept a user-controlled filepath parameter and open the specified file for reading without calling validatesafepath(). An authenticated MCP client can supply an arbitrary path such as /etc/passwd or /proc/self/environ, causing the server process to read and transmit the file's contents to the remote Atlassian instance as an attachment. This is an incomplete fix relative to GHSA-xjgw-4wvw-rgm4: the downloadattachment and downloadissueattachments paths were hardened with validatesafepath(), but the upload direction was left unguarded in both the Jira and Confluence modules. --- Details Affected functions: | File | Function | Line | |------|----------|------| | src/mcpatlassian/jira/attachments.py | uploadattachment() | ~372–415 | | src/mcpatlassian/confluence/attachments.py | uploadattachment() | ~62–108 | | src/mcpatlassian/confluence/attachments.py | uploadattachmentdirect() | ~476–477 | Jira — vulnerable…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mfv2-4wvm-9pgp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-mfv2-4wvm-9pgp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-mfv2-4wvm-9pgp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77266

Advisory: MCP Atlassian: Path traversal in upload_attachment allows arbitrary file read and exfiltration via MCP tool call
IDs: CVE-2026-77266, GHSA-mfv2-4wvm-9pgp
Record: https://patchnext.com/advisories/cve-2026-77266 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-atlassian 0.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp-atlassian: affected < 0.22.0; fixed in 0.22.0

## Suggested inspection (read-only)
- `python -m pip show mcp-atlassian`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-atlassian.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mfv2-4wvm-9pgp (GitHub-reviewed advisory GHSA-mfv2-4wvm-9pgp lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0)
- Verified: https://osv.dev/vulnerability/GHSA-mfv2-4wvm-9pgp (OSV record GHSA-mfv2-4wvm-9pgp lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…