Skip to content

← Actionable
High, CVSS 7.1amended

MCP Atlassian: SSRF redirect protection missing for basic-auth and OAuth authentication branches

CVE-2026-77261GHSA-6529-c226-h328

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-atlassian 0.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-77261: 0.37% estimated exploitation activity in the next 30 days; percentile 31.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary makessrfsafehook() blocks HTTP redirects to private/internal IPs by validating the Location header before the client follows a 3xx response. The problem is that this hook is only attached in one of three authentication branches — the header-PAT path. Basic auth and OAuth branches skip it entirely, so if the connected Atlassian server returns a redirect to something like http://169.254.169.254/, the requests session follows it without complaint. This is an incomplete fix for GHSA-7r34-79r5-rcc9. The hook works fine when it's there — it just isn't there for most production auth configurations. Details In src/mcpatlassian/servers/dependencies.py, three branches construct a fetcher and call createandvalidate(). Only Branch 1 passes attachssrfhook=True: attachssrfhook defaults to False, so branches 2 and 3 silently skip the protection. The hook itself (makessrfsafehook) is straightforward — it checks response.isredirect, grabs the Location header, and calls validateurlforssrf() to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6529-c226-h328

  2. Revision 2 · amended ·

    Amended from osv record GHSA-6529-c226-h328

  3. Revision 1 · created ·

    Published from ghsa record GHSA-6529-c226-h328

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77261

Advisory: MCP Atlassian: SSRF redirect protection missing for basic-auth and OAuth authentication branches
IDs: CVE-2026-77261, GHSA-6529-c226-h328
Record: https://patchnext.com/advisories/cve-2026-77261 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-atlassian 0.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp-atlassian: affected < 0.22.0; fixed in 0.22.0

## Suggested inspection (read-only)
- `python -m pip show mcp-atlassian`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-atlassian.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6529-c226-h328 (GitHub-reviewed advisory GHSA-6529-c226-h328 lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0)
- Verified: https://osv.dev/vulnerability/GHSA-6529-c226-h328 (OSV record GHSA-6529-c226-h328 lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…