Skip to content

← Actionable
Low, CVSS 2.1amended

Prefect Git Argument Injection in GitRepository Pull Steps

CVE-2026-7725GHSA-6rcx-55r6-jx65

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (prefect 3.6.25.dev7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI prefect

    Affected
    < 3.6.25.dev7
    Fixed in
    3.6.25.dev7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-7725: 0.25% estimated exploitation activity in the next 30 days; percentile 16.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in PrefectHQ prefect up to 3.6.25.dev6. Affected by this issue is some unknown functionality of the file src/prefect/runner/storage.py of the component GitRepository Pull Handler. The manipulation of the argument commitsha/directories results in argument injection. It is possible to launch the attack remotely. The exploit has been made public and could be used. Upgrading to version 3.6.25.dev7 can resolve this issue. The patch is identified as 6a9d9918716ce4ee0297b69f3046f7067ef1faae. It is advisable to upgrade the affected component.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6rcx-55r6-jx65

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6rcx-55r6-jx65

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-7725

Advisory: Prefect Git Argument Injection in GitRepository Pull Steps
IDs: CVE-2026-7725, GHSA-6rcx-55r6-jx65
Record: https://patchnext.com/advisories/cve-2026-7725 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: prefect 3.6.25.dev7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI prefect: affected < 3.6.25.dev7; fixed in 3.6.25.dev7

## Suggested inspection (read-only)
- `python -m pip show prefect`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on prefect.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6rcx-55r6-jx65 (OSV record GHSA-6rcx-55r6-jx65 lists affected ranges: PyPI prefect >=0 <3.6.25.dev7 (fixed))
- Verified: https://github.com/advisories/GHSA-6rcx-55r6-jx65 (GitHub-reviewed advisory GHSA-6rcx-55r6-jx65 lists affected ranges: PyPI prefect >=0 <3.6.25.dev7)

Commands are suggestions: review each one before running it.

Loading voting…