Skip to content

← Actionable
Critical, CVSS 10.0amended

[mcp-atlassian] Authentication bypass in HTTP transport: AtlassianOpaqueTokenVerifier accepts any non-empty token

CVE-2026-77244GHSA-wrhw-j3f9-8vc6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-atlassian 0.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-77244: 0.35% estimated exploitation activity in the next 30 days; percentile 28.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description mcp-atlassian deploys in two common patterns: Pattern A (single-user, server-side credentials): operator sets JIRAUSERNAME + JIRAAPITOKEN (or CONFLUENCEUSERNAME + CONFLUENCEAPITOKEN) in environment variables. Server uses these to call Jira/Confluence. This is the documented quickstart pattern. Pattern B (multi-user, OAuth or per-request PAT): operator sets up OAuth proxy or accepts per-user tokens via Authorization or service headers. The authentication mechanism in HTTP transport has two issues that combine to permit unauthenticated access to Pattern A deployments: 1. AtlassianOpaqueTokenVerifier.verifytoken() at src/mcpatlassian/utils/tokenverifier.py accepts any non-empty string as a valid token: async def verifytoken(self, token: str) - AccessToken | None: if not token: return None scopes = self.requiredscopes or [] return AccessToken( token=token, clientid="atlassian", scopes=scopes, expiresat=int(time.time()) + 86400 30, ) The docstring documents this: "we accept…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wrhw-j3f9-8vc6

  2. Revision 2 · amended ·

    Amended from osv record GHSA-wrhw-j3f9-8vc6

  3. Revision 1 · created ·

    Published from ghsa record GHSA-wrhw-j3f9-8vc6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77244

Advisory: [mcp-atlassian] Authentication bypass in HTTP transport: AtlassianOpaqueTokenVerifier accepts any non-empty token
IDs: CVE-2026-77244, GHSA-wrhw-j3f9-8vc6
Record: https://patchnext.com/advisories/cve-2026-77244 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-atlassian 0.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp-atlassian: affected < 0.22.0; fixed in 0.22.0

## Suggested inspection (read-only)
- `python -m pip show mcp-atlassian`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-atlassian.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wrhw-j3f9-8vc6 (GitHub-reviewed advisory GHSA-wrhw-j3f9-8vc6 lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0)
- Verified: https://osv.dev/vulnerability/GHSA-wrhw-j3f9-8vc6 (OSV record GHSA-wrhw-j3f9-8vc6 lists affected ranges: PyPI mcp-atlassian >=0 <0.22.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…