Skip to content

← Actionable
Medium, CVSS 6.1amended

justhtml: to_markdown() code-span blank-line breakout enables XSS

CVE-2026-77088GHSA-jf6w-2mvx-633j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (justhtml 1.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI justhtml

    Affected
    >= 0.9.0, <= 1.21.0
    Fixed in
    1.22.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-77088: 0.26% estimated exploitation activity in the next 30 days; percentile 18.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

justhtml: tomarkdown() code-span blank-line breakout enables XSS Summary In justhtml 0.9.0 through 1.21.0, tomarkdown() renders <code text (and <pre text inside a link) as an inline Markdown code span whose only protection is backtick-fence length. A blank line (\n\n) in that text terminates the inline span in any compliant Markdown renderer, so attacker-controlled text that survived HTML sanitization is emitted unescaped after the blank line and is re-parsed as live raw HTML/Markdown — yielding XSS in the default configuration. Likely CWE-79 (Cross-site Scripting) arising from CWE-116 (Improper Encoding/Escaping of Output). Details tomarkdown() is documented as a safety surface. docs/text.md states the guarantee applies "to the HTML produced by rendering that Markdown with a compliant Markdown renderer," and SECURITY.md promises tomarkdown() "escapes line-start Markdown markers that could change block structure" and "uses code fences long enough to contain backticks safely." The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jf6w-2mvx-633j

  2. Revision 1 · created ·

    Published from osv record GHSA-jf6w-2mvx-633j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77088

Advisory: justhtml: to_markdown() code-span blank-line breakout enables XSS
IDs: CVE-2026-77088, GHSA-jf6w-2mvx-633j
Record: https://patchnext.com/advisories/cve-2026-77088 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: justhtml 1.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI justhtml: affected >= 0.9.0, <= 1.21.0; fixed in 1.22.0

## Suggested inspection (read-only)
- `python -m pip show justhtml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on justhtml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jf6w-2mvx-633j (OSV record GHSA-jf6w-2mvx-633j lists affected ranges: PyPI justhtml >=0.9.0 <1.22.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jf6w-2mvx-633j (GitHub-reviewed advisory GHSA-jf6w-2mvx-633j lists affected ranges: PyPI justhtml >=0.9.0 <=1.21.0)

Commands are suggestions: review each one before running it.

Loading voting…