Skip to content

← Actionable
Low, CVSS 3.7amended

multer vulnerable to file size limit bypass via async fileFilter race condition

CVE-2026-77063GHSA-qvfw-j98x-7q72

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (multer 2.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm multer

    Affected
    < 2.3.0
    Fixed in
    2.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-77063: 0.23% estimated exploitation activity in the next 30 days; percentile 14.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When multer is configured with an asynchronous fileFilter, the limits.fileSize limit can be bypassed. The 'limit' event is registered inside the async fileFilter callback, so if a file exceeds limits.fileSize before that callback runs, the event is missed and the oversized upload is accepted instead of being rejected with a LIMITFILESIZE error. Applications that rely on limits.fileSize to reject oversized uploads are affected on all upload methods (.single(), .array(), .fields(), .any()). Uploads using a synchronous fileFilter are not affected. Patches Users should upgrade to 2.3.0. Workarounds Use a synchronous fileFilter, or validate the uploaded file size after the upload completes.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qvfw-j98x-7q72

  2. Revision 2 · amended ·

    Amended from osv record GHSA-qvfw-j98x-7q72

  3. Revision 1 · created ·

    Published from ghsa record GHSA-qvfw-j98x-7q72

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-77063

Advisory: multer vulnerable to file size limit bypass via async fileFilter race condition
IDs: CVE-2026-77063, GHSA-qvfw-j98x-7q72
Record: https://patchnext.com/advisories/cve-2026-77063 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: multer 2.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm multer: affected < 2.3.0; fixed in 2.3.0

## Suggested inspection (read-only)
- `npm ls multer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on multer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qvfw-j98x-7q72 (GitHub-reviewed advisory GHSA-qvfw-j98x-7q72 lists affected ranges: npm multer >=0 <2.3.0)
- Verified: https://osv.dev/vulnerability/GHSA-qvfw-j98x-7q72 (OSV record GHSA-qvfw-j98x-7q72 lists affected ranges: npm multer >=0 <2.3.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…