Skip to content

← Actionable
High, CVSS 8.8amended

Langflow: Prompt injection in Langflow Smart Transform can lead to code execution

CVE-2026-7700GHSA-9fpm-3445-2vx4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.10.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langflow

    Affected
    >= 1.3.0, < 1.10.3
    Fixed in
    1.10.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-7700: 0.31% estimated exploitation activity in the next 30 days; percentile 24.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Langflow versions 1.3.0 through 1.10.2 contain a code-injection vulnerability in the Smart Transform (LambdaFilterComponent) component. Smart Transform places flow-author instructions and a preview of its input data into a prompt asking an LLM to generate a Python lambda. It then extracts a one-line lambda from the model response, applies only syntactic format checks, evaluates it with Python's full builtins, and invokes the resulting function inside the Langflow process. A malicious flow author can exploit this directly through the Instructions field. In deployments where an exposed flow passes attacker-controlled content into Smart Transform, an attacker may also exploit it indirectly through prompt injection, subject to the configured model following the injected instruction. Vulnerability details Vulnerable Code Location: src/lfx/src/lfx/components/llmoperations/lambdafilter.py (line 242 in v1.10.2) For example, an attacker can attempt to make the model return: lambda x:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9fpm-3445-2vx4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9fpm-3445-2vx4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9fpm-3445-2vx4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-7700

Advisory: Langflow: Prompt injection in Langflow Smart Transform can lead to code execution
IDs: CVE-2026-7700, GHSA-9fpm-3445-2vx4
Record: https://patchnext.com/advisories/cve-2026-7700 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langflow 1.10.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langflow: affected >= 1.3.0, < 1.10.3; fixed in 1.10.3

## Suggested inspection (read-only)
- `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9fpm-3445-2vx4 (GitHub-reviewed advisory GHSA-9fpm-3445-2vx4 lists affected ranges: PyPI langflow >=1.3.0 <1.10.3)
- Verified: https://osv.dev/vulnerability/GHSA-9fpm-3445-2vx4 (OSV record GHSA-9fpm-3445-2vx4 lists affected ranges: PyPI langflow >=1.3.0 <1.10.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…