Skip to content

← Actionable
Medium, CVSS 5.3amended

Unleash: Clone-feature lets a user copy a feature from a project they cannot read

CVE-2026-76910GHSA-8xcj-9hfr-fh9j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (unleash-server 8.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-76910: 0.41% estimated exploitation activity in the next 30 days; percentile 35.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The clone-feature endpoint supports copying features across projects, but it does not verify that the caller can access the source project. A user with create permissions in one project can clone a feature from another project they cannot read and then inspect the copied configuration. This vulnerability cannot be confirmed without Enterprise access. Report is based on a circumstantial evidence in the open-source repository. Details src/lib/features/feature-toggle/feature-toggle-service.ts implements cloneFeatureToggle. This operation needs authorization for both sides: permission to read/copy the source feature and permission to create the destination feature. The clone path validates permissions against the destination project, but not against the source project that owns featureName. Because feature names are globally unique, a caller can reference a feature outside projects they can access. PoC 1. Create or identify two projects: P1 with a private or restricted feature…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-8xcj-9hfr-fh9j

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-8xcj-9hfr-fh9j

  4. Revision 1 · created ·

    Published from ghsa record GHSA-8xcj-9hfr-fh9j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-76910

Advisory: Unleash: Clone-feature lets a user copy a feature from a project they cannot read
IDs: CVE-2026-76910, GHSA-8xcj-9hfr-fh9j
Record: https://patchnext.com/advisories/cve-2026-76910 (revision 4, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: unleash-server 8.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm unleash-server: affected < 8.0.3; fixed in 8.0.3

## Suggested inspection (read-only)
- `npm ls unleash-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on unleash-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8xcj-9hfr-fh9j (GitHub-reviewed advisory GHSA-8xcj-9hfr-fh9j lists affected ranges: npm unleash-server >=0 <8.0.3)
- Verified: https://osv.dev/vulnerability/GHSA-8xcj-9hfr-fh9j (OSV record GHSA-8xcj-9hfr-fh9j lists affected ranges: npm unleash-server >=0 <8.0.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…