Unleash: CR-approval email renders user-controlled raw HTML
CVE-2026-76909GHSA-7hvx-28gp-mf6j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (unleash-server 8.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm unleash-server
- Affected
- < 8.0.3
- Fixed in
- 8.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7hvx-28gp-mf6j lists affected ranges: npm unleash-server >=0 <8.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7hvx-28gp-mf6j lists affected ranges: npm unleash-server >=0 <8.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-76909: 0.47% estimated exploitation activity in the next 30 days; percentile 40.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The change-request approval HTML email template renders fields as raw HTML. User who can create a change request can inject HTML into approval notification emails. I was not able to confirm Enterprise platform is using vulnerable code nor that it doesn't sanitize input. Details src/mailtemplates/requested-cr-approval/requested-cr-approval.html.mustache uses Mustache triple-stash syntax for fields that can originate from users: Triple-stash disables HTML escaping even when Mustache's global escape function is safe. The related renderer is sendRequestedCRApprovalEmail in src/lib/services/email-service.ts, which renders the template with Mustache.render. PoC 1. Use an Enterprise deployment with change requests and approval emails enabled. 2. As a project member who can create change requests, set a display name or change-request title to HTML such as: 3. Create a change request that requires approval. 4. Observe that the approval email contains attacker-controlled raw HTML…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-7hvx-28gp-mf6j
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-7hvx-28gp-mf6j
- Revision 1 · created ·
Published from ghsa record GHSA-7hvx-28gp-mf6j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-76909 Advisory: Unleash: CR-approval email renders user-controlled raw HTML IDs: CVE-2026-76909, GHSA-7hvx-28gp-mf6j Record: https://patchnext.com/advisories/cve-2026-76909 (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: unleash-server 8.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm unleash-server: affected < 8.0.3; fixed in 8.0.3 ## Suggested inspection (read-only) - `npm ls unleash-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on unleash-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7hvx-28gp-mf6j (GitHub-reviewed advisory GHSA-7hvx-28gp-mf6j lists affected ranges: npm unleash-server >=0 <8.0.3) - Verified: https://osv.dev/vulnerability/GHSA-7hvx-28gp-mf6j (OSV record GHSA-7hvx-28gp-mf6j lists affected ranges: npm unleash-server >=0 <8.0.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…