kin-openapi openai3filter: nil-pointer panic in ConvertErrors on malformed multipart/form-data body enables unauthenticated DoS
CVE-2026-76905GHSA-mmfr-pmjx-hw9w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/getkin/kin-openapi 0.141.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/getkin/kin-openapi
- Affected
- >= 0.10.0, < 0.141.0
- Fixed in
- 0.141.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mmfr-pmjx-hw9w lists affected ranges: Go github.com/getkin/kin-openapi >=0.10.0 <0.141.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6274 lists affected ranges: Go github.com/getkin/kin-openapi >=0.10.0 <0.141.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mmfr-pmjx-hw9w lists affected ranges: Go github.com/getkin/kin-openapi >=0.10.0 <0.141.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-76905: 0.61% estimated exploitation activity in the next 30 days; percentile 49.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A nil-pointer dereference in openapi3filter.ConvertErrors lets any unauthenticated client crash a server with a single HTTP request. When an application validates a multipart/form-data request body and renders the resulting validation error through the library-provided ValidationErrorEncoder / ConvertErrors helpers, a malformed scalar form field (e.g. a non-numeric value for an integer property) produces an error shape that convertParseError dereferences without a nil check. The handler goroutine panics, causing a denial of service. application/json request bodies are not affected — the bug is specific to multipart/form-data. Details The panic is in convertParseError, at openapi3filter/validationerrorencoder.go:119-120 (still present on master at the time of writing): The comparison e.Parameter.In == "query" assumes e.Parameter is non-nil. It is reached whenever both of the following hold: 1. e.Parameter == nil. A RequestError carries either Parameter (parameter errors) or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mmfr-pmjx-hw9w
- Revision 2 · amended ·
Amended from osv record GO-2026-6274
- Revision 1 · created ·
Published from osv record GHSA-mmfr-pmjx-hw9w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-76905 Advisory: kin-openapi openai3filter: nil-pointer panic in ConvertErrors on malformed multipart/form-data body enables unauthenticated DoS IDs: CVE-2026-76905, GHSA-mmfr-pmjx-hw9w Record: https://patchnext.com/advisories/cve-2026-76905 (revision 3, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/getkin/kin-openapi 0.141.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/getkin/kin-openapi: affected >= 0.10.0, < 0.141.0; fixed in 0.141.0 ## Suggested inspection (read-only) - Go github.com/getkin/kin-openapi: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/getkin/kin-openapi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mmfr-pmjx-hw9w (OSV record GHSA-mmfr-pmjx-hw9w lists affected ranges: Go github.com/getkin/kin-openapi >=0.10.0 <0.141.0 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6274 (OSV record GO-2026-6274 lists affected ranges: Go github.com/getkin/kin-openapi >=0.10.0 <0.141.0 (fixed)) - Verified: https://github.com/advisories/GHSA-mmfr-pmjx-hw9w (GitHub-reviewed advisory GHSA-mmfr-pmjx-hw9w lists affected ranges: Go github.com/getkin/kin-openapi >=0.10.0 <0.141.0) Commands are suggestions: review each one before running it.
Loading voting…