GeoTools has unauthenticated SQL injection in the jsonArrayContains filter function against PostGIS layers
CVE-2026-76904GHSA-mqjf-5f49-2fjh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geotools.jdbc:gt-jdbc-postgis 35.1, 34.5, 33.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.geotools.jdbc:gt-jdbc-postgis
- Affected
- >= 35.0, <= 35.0>= 34.0, < 34.5>= 30.5, < 33.6
- Fixed in
- 35.1, 33.6, 34.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mqjf-5f49-2fjh lists affected ranges: Maven org.geotools.jdbc:gt-jdbc-postgis >=35.0 =34.0 =30.5 <33.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mqjf-5f49-2fjh lists affected ranges: Maven org.geotools.jdbc:gt-jdbc-postgis >=35.0 =34.0 =30.5 <33.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-76904: 3.98% estimated exploitation activity in the next 30 days; percentile 90.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An SQL Injection Vulnerability has been found when executing OGC Filters with PostGIS DataStore implementation: jsonArrayContains function Requires PostGIS 12 or greater with a String or JSON field For PostGIS 12 and greater jsonArrayContains(<column, <pointer, <value) function writes <value into generated SQL without escaping. Patches GeoTools 35.1 GeoTools 33.5 GeoTools 34.4 Mitigation No mitigation is available: To limit scope of SQL Injection the PostGIS connection pool should be configured with limited rights. Impact This vulnerability can lead to execution of arbitrary SQL expressions in the database. References https://osgeo-org.atlassian.net/browse/GEOT-7958 https://osgeo-org.atlassian.net/browse/GEOT-7959 https://github.com/geotools/geotools/pull/5829 https://osgeo-org.atlassian.net/browse/GEOT-7589
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mqjf-5f49-2fjh
- Revision 1 · created ·
Published from osv record GHSA-mqjf-5f49-2fjh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-76904 Advisory: GeoTools has unauthenticated SQL injection in the jsonArrayContains filter function against PostGIS layers IDs: CVE-2026-76904, GHSA-mqjf-5f49-2fjh Record: https://patchnext.com/advisories/cve-2026-76904 (revision 2, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.geotools.jdbc:gt-jdbc-postgis 35.1, 34.5, 33.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.geotools.jdbc:gt-jdbc-postgis: affected >= 35.0, <= 35.0; >= 34.0, < 34.5; >= 30.5, < 33.6; fixed in 35.1, 33.6, 34.5 ## Suggested inspection (read-only) - Maven org.geotools.jdbc:gt-jdbc-postgis: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.geotools.jdbc:gt-jdbc-postgis. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mqjf-5f49-2fjh (OSV record GHSA-mqjf-5f49-2fjh lists affected ranges: Maven org.geotools.jdbc:gt-jdbc-postgis >=35.0 =34.0 =30.5 <33.6 (fixed)) - Verified: https://github.com/advisories/GHSA-mqjf-5f49-2fjh (GitHub-reviewed advisory GHSA-mqjf-5f49-2fjh lists affected ranges: Maven org.geotools.jdbc:gt-jdbc-postgis >=35.0 =34.0 =30.5 <33.6) Commands are suggestions: review each one before running it.
Loading voting…