Skip to content

← Actionable
High, CVSS 7.1amended

stigmem-node's federation peer token timestamp validation may reject valid peer tokens

CVE-2026-76245GHSA-xh5j-xjfq-qvvx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (stigmem-node 0.9.0a2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-76245: 0.24% estimated exploitation activity in the next 30 days; percentile 14.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A mismatch in federation peer-token timestamp handling could cause valid peer tokens to be treated as expired. Impacted deployments are Stigmem nodes using federation peer authentication paths from affected versions. The primary impact is availability and reliability of authenticated federation flows. Patches Patched in 0.9.0a2. Federation peer-token timestamp handling now uses the canonical millisecond-based validation path and is covered by regression tests. Workarounds Before upgrading, avoid mixed peer-token minting paths and restrict federation use to tightly controlled peers. Upgrade Upgrade to the patched release: If developers install through the Stigmem meta-package instead, they should use the matching extra for deployments, for example: Resources - Release: https://github.com/eidetic-labs/stigmem/releases/tag/v0.9.0a2 - Changelog: https://github.com/eidetic-labs/stigmem/blob/v0.9.0a2/CHANGELOG.md#L14-L35 - Security policy and posture:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xh5j-xjfq-qvvx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xh5j-xjfq-qvvx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-76245

Advisory: stigmem-node's federation peer token timestamp validation may reject valid peer tokens
IDs: CVE-2026-76245, GHSA-xh5j-xjfq-qvvx
Record: https://patchnext.com/advisories/cve-2026-76245 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: stigmem-node 0.9.0a2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI stigmem-node: affected < 0.9.0a2; fixed in 0.9.0a2

## Suggested inspection (read-only)
- `python -m pip show stigmem-node`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on stigmem-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xh5j-xjfq-qvvx (OSV record GHSA-xh5j-xjfq-qvvx lists affected ranges: PyPI stigmem-node >=0 <0.9.0a2 (fixed))
- Verified: https://github.com/advisories/GHSA-xh5j-xjfq-qvvx (GitHub-reviewed advisory GHSA-xh5j-xjfq-qvvx lists affected ranges: PyPI stigmem-node >=0 <0.9.0a2)

Commands are suggestions: review each one before running it.

Loading voting…