stigmem-node's unsigned plugin override could be enabled without a second explicit acknowledgment
CVE-2026-76241GHSA-w7pm-9g55-mxfm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (stigmem-node 0.9.0a2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI stigmem-node
- Affected
- < 0.9.0a2
- Fixed in
- 0.9.0a2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w7pm-9g55-mxfm lists affected ranges: PyPI stigmem-node >=0 <0.9.0a2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w7pm-9g55-mxfm lists affected ranges: PyPI stigmem-node >=0 <0.9.0a2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-76241: 0.11% estimated exploitation activity in the next 30 days; percentile 1.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A single configuration flag could disable plugin signature enforcement. If an operator unintentionally carried that setting into an environment where plugin paths are writable by less-trusted users, unsigned plugin code could be loaded. Patches Patched in 0.9.0a2. Disabling plugin signature enforcement now requires a second explicit acknowledgment value. Workarounds Before upgrading, keep plugin signing required in all shared or production environments and ensure plugin directories are not writable by untrusted users. Upgrade Upgrade to the patched release: If developers install through the Stigmem meta-package instead, they should use the matching extra for deployments, for example: Resources - Release: https://github.com/eidetic-labs/stigmem/releases/tag/v0.9.0a2 - Changelog: https://github.com/eidetic-labs/stigmem/blob/v0.9.0a2/CHANGELOG.md#L14-L35 - Security policy and posture: https://github.com/eidetic-labs/stigmem/blob/v0.9.0a2/SECURITY.md
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w7pm-9g55-mxfm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w7pm-9g55-mxfm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-76241 Advisory: stigmem-node's unsigned plugin override could be enabled without a second explicit acknowledgment IDs: CVE-2026-76241, GHSA-w7pm-9g55-mxfm Record: https://patchnext.com/advisories/cve-2026-76241 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: stigmem-node 0.9.0a2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI stigmem-node: affected < 0.9.0a2; fixed in 0.9.0a2 ## Suggested inspection (read-only) - `python -m pip show stigmem-node`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on stigmem-node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w7pm-9g55-mxfm (OSV record GHSA-w7pm-9g55-mxfm lists affected ranges: PyPI stigmem-node >=0 <0.9.0a2 (fixed)) - Verified: https://github.com/advisories/GHSA-w7pm-9g55-mxfm (GitHub-reviewed advisory GHSA-w7pm-9g55-mxfm lists affected ranges: PyPI stigmem-node >=0 <0.9.0a2) Commands are suggestions: review each one before running it.
Loading voting…