Skip to content

← Actionable
High, CVSS 7.2amended

stigmem-node: decay sweep expires and counts facts across all tenants (cross-tenant BOLA)

CVE-2026-76238GHSA-6gqw-jqv7-v88m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (stigmem-node 0.9.0a12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-76238: 0.36% estimated exploitation activity in the next 30 days; percentile 30.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary On a multi-tenant stigmem node, a caller holding a write credential for one tenant can run a decay sweep that acts on every tenant's facts. The candidate-selection queries in lifecycle/decay.py (selectttlcandidates, selectconfidencecandidates) carried no tenantid predicate, and the caller's tenant was not threaded into the sweep or its async worker (rundecaysweep / decayjobworker), reached via POST /v1/decay/sweep. Impact A sweep with ttlseconds=0 expires all tenants' facts — cross-tenant data destruction (integrity and availability). A dryrun sweep returns a global candidate count, acting as a cross-tenant existence/volume oracle (information disclosure). Affected configurations This is a cross-tenant break. It is exploitable only on deployments running the opt-in stigmem-plugin-multi-tenant (multiple tenants on one node). A default single-tenant node has only tenant="default" — there is no second tenant to cross — so it is not exploitable on default deployments. The rating…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6gqw-jqv7-v88m

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6gqw-jqv7-v88m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-76238

Advisory: stigmem-node: decay sweep expires and counts facts across all tenants (cross-tenant BOLA)
IDs: CVE-2026-76238, GHSA-6gqw-jqv7-v88m
Record: https://patchnext.com/advisories/cve-2026-76238 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: stigmem-node 0.9.0a12. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI stigmem-node: affected < 0.9.0a12; fixed in 0.9.0a12

## Suggested inspection (read-only)
- `python -m pip show stigmem-node`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on stigmem-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6gqw-jqv7-v88m (OSV record GHSA-6gqw-jqv7-v88m lists affected ranges: PyPI stigmem-node >=0 <0.9.0a12 (fixed))
- Verified: https://github.com/advisories/GHSA-6gqw-jqv7-v88m (GitHub-reviewed advisory GHSA-6gqw-jqv7-v88m lists affected ranges: PyPI stigmem-node >=0 <0.9.0a12)

Commands are suggestions: review each one before running it.

Loading voting…