Skip to content

← Actionable
Medium, CVSS 6.7amended

Renovate vulnerable to arbitrary command injection via Gradle Wrapper and malicious distributionUrl

CVE-2026-76228GHSA-pfq2-hh62-7m96

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (renovate 42.68.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm renovate

    Affected
    >= 32.124.0, < 42.68.5
    Fixed in
    42.68.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.7 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-76228: 0.96% estimated exploitation activity in the next 30 days; percentile 61.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Renovate can be tricked into executing shell code while updating the Gradle Wrapper. A malicious distributionUrl in gradle/wrapper/gradle-wrapper.properties can lead to command execution in the Renovate runtime. Details When Renovate handles Gradle Wrapper artifacts, it may run a wrapper update command such as: - ./gradlew :wrapper --gradle-distribution-url <value In the observed behavior, Renovate executes this via a shell (e.g., /bin/sh -c ...). If distributionUrl contains shell command substitution syntax like $(...), the shell evaluates it before Gradle validates/parses the URL. After that, Gradle attempts to parse the URL as a URI and fails with URISyntaxException, but the shell substitution has already executed. This is reproducible even when allowScripts is disabled (default is OFF), because this execution happens as part of Gradle Wrapper artifact handling rather than “repository install scripts”. Prerequisites / attack conditions: - The attacker must be able to get a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pfq2-hh62-7m96

  2. Revision 1 · created ·

    Published from osv record GHSA-pfq2-hh62-7m96

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-76228

Advisory: Renovate vulnerable to arbitrary command injection via Gradle Wrapper and malicious `distributionUrl`
IDs: CVE-2026-76228, GHSA-pfq2-hh62-7m96
Record: https://patchnext.com/advisories/cve-2026-76228 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: renovate 42.68.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm renovate: affected >= 32.124.0, < 42.68.5; fixed in 42.68.5

## Suggested inspection (read-only)
- `npm ls renovate --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on renovate.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pfq2-hh62-7m96 (OSV record GHSA-pfq2-hh62-7m96 lists affected ranges: npm renovate >=32.124.0 <42.68.5 (fixed))
- Verified: https://github.com/advisories/GHSA-pfq2-hh62-7m96 (GitHub-reviewed advisory GHSA-pfq2-hh62-7m96 lists affected ranges: npm renovate >=32.124.0 <42.68.5)

Commands are suggestions: review each one before running it.

Loading voting…