Skip to content

← Actionable
High, CVSS 7.5

fast-uri vulnerable to host confusion via percent-encoded scheme normalization

CVE-2026-76172GHSA-jqff-g426-hqxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.1.3, 3.1.6, 2.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-uri

    Affected
    >= 2.3.1, < 2.4.5>= 3.0.0, < 3.1.6>= 4.0.0, < 4.1.3
    Fixed in
    2.4.5, 4.1.3, 3.1.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-76172: 0.23% estimated exploitation activity in the next 30 days; percentile 14.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact fast-uri decodes percent-encoded characters in the scheme component with the legacy global unescape() and serializes the result back as raw characters, without re-escaping it or validating it as a scheme. A scheme that decodes to characters outside the RFC 3986 scheme grammar can therefore introduce structure the original input did not contain. For example, %2f%2fevil.example:/pwn parses with no authority (parse().host is undefined), but resolve() and normalize() return //evil.example:/pwn, which reparses with host evil.example. The %uXXXX form (%u002f%u002fevil.example:/pwn) produces the same result, and a scheme containing %0d%0a reaches the output as a raw CR LF. Applications that normalize or resolve untrusted URLs before a redirect check, host allowlist, or outbound request decision, especially ones that treat a missing authority as same-origin, can be steered to an attacker-chosen authority, and a normalized URI placed in a response header can carry an injected CR LF.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jqff-g426-hqxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-76172

Advisory: fast-uri vulnerable to host confusion via percent-encoded scheme normalization
IDs: CVE-2026-76172, GHSA-jqff-g426-hqxp
Record: https://patchnext.com/advisories/cve-2026-76172 (revision 1, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.1.3, 3.1.6, 2.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-uri: affected >= 2.3.1, < 2.4.5; >= 3.0.0, < 3.1.6; >= 4.0.0, < 4.1.3; fixed in 2.4.5, 4.1.3, 3.1.6

## Suggested inspection (read-only)
- `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-uri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jqff-g426-hqxp (GitHub-reviewed advisory GHSA-jqff-g426-hqxp lists affected ranges: npm fast-uri >=2.3.1 =3.0.0 =4.0.0 <4.1.3)

Commands are suggestions: review each one before running it.

Loading voting…