Skip to content

← Actionable
High, CVSS 7.5amended

fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers

CVE-2026-76169GHSA-p68q-wchp-6fh7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify 5.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fastify

    Affected
    >= 4.0.0, < 5.12.2
    Fixed in
    5.12.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-76169: 0.53% estimated exploitation activity in the next 30 days; percentile 44.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Fastify routes a malformed URL under one plugin prefix to the custom not-found handler of a different sibling plugin, invoking the handler registered last and skipping the preHandler declared in its setNotFoundHandler(). When the request method has no route in the main router, a malformed request target reaches Fastify's internal not-found router before URL decoding and is dispatched through a single shared handler pointer, regardless of prefix and without the normal request lifecycle. An unauthenticated request to a public prefix can therefore reach an authentication-protected not-found handler registered under a different prefix and receive its full response, breaking prefix encapsulation and bypassing the authentication hook. Applications whose private or tenant fallbacks return protected data from a not-found handler are affected. Patches Patched in fastify 5.12.2. Malformed URLs are now routed through the configured onBadUrl and onMaxParamLength handlers so they fail…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p68q-wchp-6fh7

  2. Revision 2 · amended ·

    Amended from osv record GHSA-p68q-wchp-6fh7

  3. Revision 1 · created ·

    Published from ghsa record GHSA-p68q-wchp-6fh7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-76169

Advisory: fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers
IDs: CVE-2026-76169, GHSA-p68q-wchp-6fh7
Record: https://patchnext.com/advisories/cve-2026-76169 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastify 5.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fastify: affected >= 4.0.0, < 5.12.2; fixed in 5.12.2

## Suggested inspection (read-only)
- `npm ls fastify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p68q-wchp-6fh7 (GitHub-reviewed advisory GHSA-p68q-wchp-6fh7 lists affected ranges: npm fastify >=4.0.0 <5.12.2)
- Verified: https://osv.dev/vulnerability/GHSA-p68q-wchp-6fh7 (OSV record GHSA-p68q-wchp-6fh7 lists affected ranges: npm fastify >=4.0.0 <5.12.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…