Skip to content

← Actionable
High, CVSS 7.5

Mistune: Denial of Service — RecursionError via Excessive Emphasis Markers in Markdown

CVE-2026-76098GHSA-6m44-fpc8-c3rq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mistune 3.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mistune

    Affected
    >= 3.3.0, < 3.3.3
    Fixed in
    3.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-76098: 0.49% estimated exploitation activity in the next 30 days; percentile 42.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Mistune v3.3.2 is vulnerable to a Denial of Service (DoS) attack via uncontrolled recursion in the HTML rendering of deeply-nested emphasis tokens. By submitting Markdown containing approximately 1,000 consecutive asterisk characters, an attacker causes the Python process to crash with RecursionError. Details The InlineParser's processemphasisdelimiters() creates deeply nested <strong tokens from consecutive emphasis markers (every 2 asterisks add one nesting level). With 1,000 consecutive asterisks, approximately 500 levels of nesting are produced. The HTMLRenderer.rendertoken() method (src/mistune/renderers/html.py:40-57) renders these tokens recursively: when a token has children, line 48 calls self.rendertokens(token['children'], state), entering child rendering. Each nesting level produces ~2 stack frames, so 500 levels ≈ 1,000 frames, exceeding Python's default recursion limit (sys.getrecursionlimit() = 1000). The emphasis() and strong() methods (lines 80-84) wrap…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6m44-fpc8-c3rq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-76098

Advisory: Mistune: Denial of Service — RecursionError via Excessive Emphasis Markers in Markdown
IDs: CVE-2026-76098, GHSA-6m44-fpc8-c3rq
Record: https://patchnext.com/advisories/cve-2026-76098 (revision 1, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mistune 3.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mistune: affected >= 3.3.0, < 3.3.3; fixed in 3.3.3

## Suggested inspection (read-only)
- `python -m pip show mistune`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mistune.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6m44-fpc8-c3rq (GitHub-reviewed advisory GHSA-6m44-fpc8-c3rq lists affected ranges: PyPI mistune >=3.3.0 <3.3.3)

Commands are suggestions: review each one before running it.

Loading voting…