Skip to content

← Actionable
High, CVSS 7.7amended

Formie: Missing authorization on sent notification resend modal exposes submission PII

CVE-2026-76089GHSA-9rg8-2wvr-fgjh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (verbb/formie 3.1.31, 2.2.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist verbb/formie

    Affected
    >= 3.0.0, < 3.1.31< 2.2.23
    Fixed in
    2.2.23, 3.1.31

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-76089: 0.41% estimated exploitation activity in the next 30 days; percentile 35.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The control panel action formie/sent-notifications/get-resend-modal-content (SentNotificationsController::actionGetResendModalContent) performed only requireAcceptsJson() and loaded a SentNotification by request id without permission or object-level authorization checks. Any authenticated user who could invoke the action could enumerate notification IDs and read full email content — including recipient headers and the complete HTML body containing submitted form data (PII) — without formie-accessSentNotifications or equivalent permission. Sibling actions in the same controller enforced authorization. Patches Fixed in 3.1.31 (Craft 5) and 2.2.23 (Craft 4). Craft 5: canView() is enforced after loading, consistent with actionEdit. Craft 4: formie-viewSentNotifications permission is required. Workarounds Restrict CP access to trusted users only until upgraded. No configuration workaround. - Reported by Jorge González (jorge@jmilla.es)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9rg8-2wvr-fgjh

  2. Revision 1 · created ·

    Published from osv record GHSA-9rg8-2wvr-fgjh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-76089

Advisory: Formie: Missing authorization on sent notification resend modal exposes submission PII
IDs: CVE-2026-76089, GHSA-9rg8-2wvr-fgjh
Record: https://patchnext.com/advisories/cve-2026-76089 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: verbb/formie 3.1.31, 2.2.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist verbb/formie: affected >= 3.0.0, < 3.1.31; < 2.2.23; fixed in 2.2.23, 3.1.31

## Suggested inspection (read-only)
- Packagist verbb/formie: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on verbb/formie.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9rg8-2wvr-fgjh (OSV record GHSA-9rg8-2wvr-fgjh lists affected ranges: Packagist verbb/formie >=3.0.0 =0 <2.2.23 (fixed))
- Verified: https://github.com/advisories/GHSA-9rg8-2wvr-fgjh (GitHub-reviewed advisory GHSA-9rg8-2wvr-fgjh lists affected ranges: Packagist verbb/formie >=3.0.0 =0 <2.2.23)

Commands are suggestions: review each one before running it.

Loading voting…