Skip to content

← Actionable
High, CVSS 8.5amended

Formie: Integration form-settings action allows SSRF and exfiltration of stored integration credentials

CVE-2026-76086GHSA-v3f3-cmj4-cvj9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (verbb/formie 3.1.31, 2.2.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist verbb/formie

    Affected
    >= 3.0.0, < 3.1.31< 2.2.23
    Fixed in
    2.2.23, 3.1.31

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-76086: 0.51% estimated exploitation activity in the next 30 days; percentile 43.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The control panel action formie/integrations/form-settings (IntegrationsController::actionFormSettings) was reachable by any authenticated user without the appropriate form integration permissions. The action applied request-supplied settings to a fully configured integration via setAttributes($settings, false), allowing an attacker to overwrite outbound host properties (e.g. apiUrl) while the server sent stored API keys or OAuth tokens to the attacker-controlled host. The remote response was returned in the JSON body (non-blind SSRF). This is an incomplete remediation of GHSA-cvpc-hccg-wmw4. The form-settings action was excluded from the permission gate added in 3.1.28. Any site where a low-privileged user can authenticate (including front-end members on sites with public registration) could exfiltrate CRM/email-marketing/webhook integration credentials and probe internal network endpoints. Patches Fixed in 3.1.31 (Craft 5) and 2.2.23 (Craft 4). The action now requires a CP…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v3f3-cmj4-cvj9

  2. Revision 1 · created ·

    Published from osv record GHSA-v3f3-cmj4-cvj9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-76086

Advisory: Formie: Integration form-settings action allows SSRF and exfiltration of stored integration credentials
IDs: CVE-2026-76086, GHSA-v3f3-cmj4-cvj9
Record: https://patchnext.com/advisories/cve-2026-76086 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: verbb/formie 3.1.31, 2.2.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist verbb/formie: affected >= 3.0.0, < 3.1.31; < 2.2.23; fixed in 2.2.23, 3.1.31

## Suggested inspection (read-only)
- Packagist verbb/formie: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on verbb/formie.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v3f3-cmj4-cvj9 (OSV record GHSA-v3f3-cmj4-cvj9 lists affected ranges: Packagist verbb/formie >=3.0.0 =0 <2.2.23 (fixed))
- Verified: https://github.com/advisories/GHSA-v3f3-cmj4-cvj9 (GitHub-reviewed advisory GHSA-v3f3-cmj4-cvj9 lists affected ranges: Packagist verbb/formie >=3.0.0 =0 <2.2.23)

Commands are suggestions: review each one before running it.

Loading voting…