Skip to content

← Actionable
High, CVSS 7.5

fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references

CVE-2026-75931GHSA-5jgf-p345-68v8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.1.3, 3.1.6, 2.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-uri

    Affected
    >= 2.4.2, < 2.4.5>= 3.1.3, < 3.1.6>= 4.0.1, < 4.1.3
    Fixed in
    2.4.5, 4.1.3, 3.1.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-75931: 0.40% estimated exploitation activity in the next 30 days; percentile 34.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact fast-uri canonicalizes a host to its ASCII form only when the input carries an explicit scheme. When resolve() resolves a scheme-relative reference (//host/) against a scheme-bearing base, it still emits the host verbatim even though the effective scheme is known, so re-parsing the resolved URI yields a different host than the one resolve() returned. An application that resolves an untrusted reference with fast-uri and then checks or routes on the resulting host can make a policy decision on one host and reach another. This is an incomplete-fix variant of CVE-2026-13676, whose IDN canonicalization was applied only to the scheme-bearing form. Patches Upgrade to fast-uri 2.4.5, 3.1.6, or 4.1.3. resolve() now canonicalizes the host once the effective scheme is known, and fails closed if a raw non-ASCII host cannot be converted. Workarounds Resolve scheme-relative references against a base that carries a scheme before performing any host-policy or origin check.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5jgf-p345-68v8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-75931

Advisory: fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references
IDs: CVE-2026-75931, GHSA-5jgf-p345-68v8
Record: https://patchnext.com/advisories/cve-2026-75931 (revision 1, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.1.3, 3.1.6, 2.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-uri: affected >= 2.4.2, < 2.4.5; >= 3.1.3, < 3.1.6; >= 4.0.1, < 4.1.3; fixed in 2.4.5, 4.1.3, 3.1.6

## Suggested inspection (read-only)
- `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-uri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5jgf-p345-68v8 (GitHub-reviewed advisory GHSA-5jgf-p345-68v8 lists affected ranges: npm fast-uri >=2.4.2 =3.1.3 =4.0.1 <4.1.3)

Commands are suggestions: review each one before running it.

Loading voting…