Skip to content

← Actionable
High, CVSS 8.7amended

CodeWhale: image_analyze follows workspace symlinks, leaking external file bytes

CVE-2026-75914GHSA-w7wx-5q49-r59w

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm codewhale

    Affected
    >= 0.8.41, < 0.8.64
    Fixed in
    0.8.64
  • npm deepseek-tui

    Affected
    >= 0.8.32, < 0.8.41
    Fixed in
    0.8.41
  • crates.io codewhale-tui

    Affected
    >= 0.8.41, < 0.8.64
    Fixed in
    0.8.64
  • crates.io deepseek-tui

    Affected
    >= 0.8.32, <= 0.8.41
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-75914: 0.53% estimated exploitation activity in the next 30 days; percentile 44.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Maintainer resolution The CodeWhale maintainers validated this report. The affected package ranges are recorded in the advisory metadata. Version 0.8.64 contains the fix in commit 26de44a8bd5051f8f944ea60b2c37ae1d2b7d25e. Users should upgrade to 0.8.64 or later. The original reporter analysis is preserved below. Summary imageanalyze follows workspace symlinks and leaks outside-workspace file bytes to the vision endpoint The imageanalyze tool resolves its imagepath with a bare context.workspace.join instead of routing through ToolContext::resolvepath. The pre-join lexical check rejects absolute paths, Windows prefixes, and parent-dir components but never canonicalizes, so a symlink inside the workspace whose name ends in an image extension and whose target sits outside the workspace is read transparently. The tool has ReadOnly capability and the trait default makes it auto-approved, so the bypass executes with no user prompt. Details In crates/tui/src/vision/tools.rs (v0.8.37, lines…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w7wx-5q49-r59w

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-w7wx-5q49-r59w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-75914

Advisory: CodeWhale: image_analyze follows workspace symlinks, leaking external file bytes
IDs: CVE-2026-75914, GHSA-w7wx-5q49-r59w
Record: https://patchnext.com/advisories/cve-2026-75914 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: codewhale 0.8.64; deepseek-tui 0.8.41; codewhale-tui 0.8.64. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm codewhale: affected >= 0.8.41, < 0.8.64; fixed in 0.8.64
- npm deepseek-tui: affected >= 0.8.32, < 0.8.41; fixed in 0.8.41
- crates.io codewhale-tui: affected >= 0.8.41, < 0.8.64; fixed in 0.8.64
- crates.io deepseek-tui: affected >= 0.8.32, <= 0.8.41

## Suggested inspection (read-only)
- `npm ls codewhale --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls deepseek-tui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- crates.io codewhale-tui: check the installed version with your package manager.
- crates.io deepseek-tui: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on codewhale, deepseek-tui, codewhale-tui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w7wx-5q49-r59w (OSV record GHSA-w7wx-5q49-r59w lists affected ranges: crates.io deepseek-tui >=0.8.32 =0.8.32 =0.8.41 =0.8.41 <0.8.64 (fixed))
- Verified: https://github.com/advisories/GHSA-w7wx-5q49-r59w (GitHub-reviewed advisory GHSA-w7wx-5q49-r59w lists affected ranges: crates.io deepseek-tui >=0.8.32 =0.8.32 =0.8.41 =0.8.41 <0.8.64)

Commands are suggestions: review each one before running it.

Loading voting…