Skip to content

← Actionable
High, CVSS 8.5amended

CodeWhale: Argument Injection in git_show Tool Allows Arbitrary File Write Without Approval

CVE-2026-75913GHSA-7j5w-7r7x-9v27

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm codewhale

    Affected
    >= 0.8.41, < 0.8.64
    Fixed in
    0.8.64
  • npm deepseek-tui

    Affected
    >= 0.3.27, < 0.8.41
    Fixed in
    0.8.41
  • crates.io codewhale-tui

    Affected
    >= 0.8.41, < 0.8.64
    Fixed in
    0.8.64
  • crates.io deepseek-tui

    Affected
    >= 0.3.27, <= 0.8.41
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H · score source
EPSS
  • CVE-2026-75913: 0.48% estimated exploitation activity in the next 30 days; percentile 41.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Maintainer resolution The CodeWhale maintainers validated this report. The affected package ranges are recorded in the advisory metadata. Version 0.8.64 contains the fix in commit 9a34b5034d29f05d1f28fa61b04719ca6a741020. Users should upgrade to 0.8.64 or later. The original reporter analysis is preserved below. Argument Injection in gitshow Tool Allows Arbitrary File Write Without Approval Overview The gitshow tool in DeepSeek-TUI executes git show with the model-supplied rev parameter passed unvalidated into the argv. git show honours the --output=<path option, so a rev value beginning with --output= is interpreted as a flag rather than a revision. The tool is registered with ApprovalRequirement::Auto and declares ToolCapability::ReadOnly, so the write happens without a user prompt and contradicts the capability the catalog advertises to the model and the user. This is the same vulnerability class as GHSA-72w5-pf8h-xfp4 (CVE-2026-45374): an auto-approved tool produces an effect…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7j5w-7r7x-9v27

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7j5w-7r7x-9v27

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-75913

Advisory: CodeWhale: Argument Injection in `git_show` Tool Allows Arbitrary File Write Without Approval
IDs: CVE-2026-75913, GHSA-7j5w-7r7x-9v27
Record: https://patchnext.com/advisories/cve-2026-75913 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: codewhale 0.8.64; deepseek-tui 0.8.41; codewhale-tui 0.8.64. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm codewhale: affected >= 0.8.41, < 0.8.64; fixed in 0.8.64
- npm deepseek-tui: affected >= 0.3.27, < 0.8.41; fixed in 0.8.41
- crates.io codewhale-tui: affected >= 0.8.41, < 0.8.64; fixed in 0.8.64
- crates.io deepseek-tui: affected >= 0.3.27, <= 0.8.41

## Suggested inspection (read-only)
- `npm ls codewhale --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls deepseek-tui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- crates.io codewhale-tui: check the installed version with your package manager.
- crates.io deepseek-tui: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on codewhale, deepseek-tui, codewhale-tui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7j5w-7r7x-9v27 (OSV record GHSA-7j5w-7r7x-9v27 lists affected ranges: crates.io deepseek-tui >=0.3.27 =0.3.27 =0.8.41 =0.8.41 <0.8.64 (fixed))
- Verified: https://github.com/advisories/GHSA-7j5w-7r7x-9v27 (GitHub-reviewed advisory GHSA-7j5w-7r7x-9v27 lists affected ranges: crates.io deepseek-tui >=0.3.27 =0.3.27 =0.8.41 =0.8.41 <0.8.64)

Commands are suggestions: review each one before running it.

Loading voting…