CodeWhale: Argument Injection in git_blame Tool Allows Arbitrary File Read Without Approval
CVE-2026-75912GHSA-c6mw-8xh8-gpq6
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm codewhale
- Affected
- >= 0.8.41, < 0.8.64
- Fixed in
- 0.8.64
npm deepseek-tui
- Affected
- >= 0.3.27, < 0.8.41
- Fixed in
- 0.8.41
crates.io codewhale-tui
- Affected
- >= 0.8.41, < 0.8.64
- Fixed in
- 0.8.64
crates.io deepseek-tui
- Affected
- >= 0.3.27, <= 0.8.41
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c6mw-8xh8-gpq6 lists affected ranges: crates.io deepseek-tui >=0.3.27 =0.3.27 =0.8.41 =0.8.41 <0.8.64 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c6mw-8xh8-gpq6 lists affected ranges: crates.io deepseek-tui >=0.3.27 =0.3.27 =0.8.41 =0.8.41 <0.8.64
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2026-75912: 0.45% estimated exploitation activity in the next 30 days; percentile 38.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Maintainer resolution The CodeWhale maintainers validated this report. The affected package ranges are recorded in the advisory metadata. Version 0.8.64 contains the fix in commit 9a34b5034d29f05d1f28fa61b04719ca6a741020. Users should upgrade to 0.8.64 or later. The original reporter analysis is preserved below. Argument Injection in gitblame Tool Allows Arbitrary File Read Without Approval Overview The gitblame tool in DeepSeek-TUI passes the model-supplied rev parameter unvalidated into the argv of git blame. git blame accepts --contents=<file, which causes it to use the file's contents in place of the working tree and echo each line verbatim in the blame output. A rev value of --contents=/path/to/secret therefore exfiltrates the targeted file's contents into the tool result, which is returned to the model and displayed in the chat transcript. The tool is registered with ApprovalRequirement::Auto and declares ToolCapability::ReadOnly. The read is in-scope for the capability label,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-c6mw-8xh8-gpq6
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-c6mw-8xh8-gpq6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-75912 Advisory: CodeWhale: Argument Injection in `git_blame` Tool Allows Arbitrary File Read Without Approval IDs: CVE-2026-75912, GHSA-c6mw-8xh8-gpq6 Record: https://patchnext.com/advisories/cve-2026-75912 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: codewhale 0.8.64; deepseek-tui 0.8.41; codewhale-tui 0.8.64. A vendor fix does not mean a deployment is fixed. ## Affected components - npm codewhale: affected >= 0.8.41, < 0.8.64; fixed in 0.8.64 - npm deepseek-tui: affected >= 0.3.27, < 0.8.41; fixed in 0.8.41 - crates.io codewhale-tui: affected >= 0.8.41, < 0.8.64; fixed in 0.8.64 - crates.io deepseek-tui: affected >= 0.3.27, <= 0.8.41 ## Suggested inspection (read-only) - `npm ls codewhale --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls deepseek-tui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - crates.io codewhale-tui: check the installed version with your package manager. - crates.io deepseek-tui: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on codewhale, deepseek-tui, codewhale-tui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c6mw-8xh8-gpq6 (OSV record GHSA-c6mw-8xh8-gpq6 lists affected ranges: crates.io deepseek-tui >=0.3.27 =0.3.27 =0.8.41 =0.8.41 <0.8.64 (fixed)) - Verified: https://github.com/advisories/GHSA-c6mw-8xh8-gpq6 (GitHub-reviewed advisory GHSA-c6mw-8xh8-gpq6 lists affected ranges: crates.io deepseek-tui >=0.3.27 =0.3.27 =0.8.41 =0.8.41 <0.8.64) Commands are suggestions: review each one before running it.
Loading voting…