Skip to content

← Actionable
High, CVSS 8.5amended

CodeWhale: Project config allow_shell override enables arbitrary shell command execution via cloned repository

CVE-2026-75911GHSA-gx45-xrj5-g6c4

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm codewhale

    Affected
    >= 0.8.41, < 0.8.64
    Fixed in
    0.8.64
  • npm deepseek-tui

    Affected
    >= 0.8.6, < 0.8.41
    Fixed in
    0.8.41
  • crates.io codewhale-tui

    Affected
    >= 0.8.41, < 0.8.64
    Fixed in
    0.8.64
  • crates.io deepseek-tui

    Affected
    >= 0.8.6, <= 0.8.41
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-75911: 0.25% estimated exploitation activity in the next 30 days; percentile 15.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Maintainer resolution The CodeWhale maintainers validated this report. The affected package ranges are recorded in the advisory metadata. Version 0.8.64 contains the fix in commit 43563356b98c6b993085554da82e77370160a31c. Users should upgrade to 0.8.64 or later. The original reporter analysis is preserved below. Summary A malicious .codewhale/config.toml or .deepseek/config.toml committed to a repository can silently set allowshell = true for any user who clones and opens the repository in CodeWhale. This enables the AI model's execshell tool, granting arbitrary shell command execution on the victim's machine without the user's explicit opt-in. The approvalpolicy and sandboxmode fields correctly enforce tightening-only semantics from project config, but allowshell has no such guard, contradicting the intent of GHSA-72w5-pf8h-xfp4 which established allowshell as an opt-in security boundary. Details The project config merge function at crates/tui/src/main.rs:5181-5182 (v0.8.50)…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gx45-xrj5-g6c4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-gx45-xrj5-g6c4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-75911

Advisory: CodeWhale: Project config `allow_shell` override enables arbitrary shell command execution via cloned repository
IDs: CVE-2026-75911, GHSA-gx45-xrj5-g6c4
Record: https://patchnext.com/advisories/cve-2026-75911 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: codewhale 0.8.64; deepseek-tui 0.8.41; codewhale-tui 0.8.64. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm codewhale: affected >= 0.8.41, < 0.8.64; fixed in 0.8.64
- npm deepseek-tui: affected >= 0.8.6, < 0.8.41; fixed in 0.8.41
- crates.io codewhale-tui: affected >= 0.8.41, < 0.8.64; fixed in 0.8.64
- crates.io deepseek-tui: affected >= 0.8.6, <= 0.8.41

## Suggested inspection (read-only)
- `npm ls codewhale --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls deepseek-tui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- crates.io codewhale-tui: check the installed version with your package manager.
- crates.io deepseek-tui: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on codewhale, deepseek-tui, codewhale-tui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gx45-xrj5-g6c4 (OSV record GHSA-gx45-xrj5-g6c4 lists affected ranges: crates.io deepseek-tui >=0.8.6 =0.8.6 =0.8.41 =0.8.41 <0.8.64 (fixed))
- Verified: https://github.com/advisories/GHSA-gx45-xrj5-g6c4 (GitHub-reviewed advisory GHSA-gx45-xrj5-g6c4 lists affected ranges: crates.io deepseek-tui >=0.8.6 =0.8.6 =0.8.41 =0.8.41 <0.8.64)

Commands are suggestions: review each one before running it.

Loading voting…