Skip to content

← Actionable
High, CVSS 7.5

fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding

CVE-2026-75899GHSA-fph4-wmhf-6fwf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-uri 4.1.3, 3.1.6, 2.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-uri

    Affected
    >= 2.4.1, < 2.4.5>= 3.1.2, < 3.1.6>= 4.0.0, < 4.1.3
    Fixed in
    2.4.5, 4.1.3, 3.1.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-75899: 0.22% estimated exploitation activity in the next 30 days; percentile 12.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact fast-uri decodes a hostname's percent escapes twice in a single normalize() or resolve() call: once during parsing and again during authority recomposition. A nested percent-encoded host therefore survives the first decode and is turned into a live destination by the second, so normalize('http://%256c%256f%2563%2561%256c%2568%256f%2573%2574/') returns http://localhost/. Applications that normalize or resolve an untrusted URI before an SSRF check, redirect validation, or host allowlist can be steered to a different destination, including internal addresses such as loopback or a cloud metadata endpoint, than the encoded input appeared to contain. This is an incomplete-fix variant of CVE-2026-6322, whose encoded-authority-delimiter fix introduced the second decode. Patches Fixed in fast-uri 2.4.5, 3.1.6, and 4.1.3. Workarounds Reject untrusted URIs whose host component contains an encoded percent sign (%25) before passing them to normalize() or resolve().

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fph4-wmhf-6fwf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-75899

Advisory: fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding
IDs: CVE-2026-75899, GHSA-fph4-wmhf-6fwf
Record: https://patchnext.com/advisories/cve-2026-75899 (revision 1, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-uri 4.1.3, 3.1.6, 2.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-uri: affected >= 2.4.1, < 2.4.5; >= 3.1.2, < 3.1.6; >= 4.0.0, < 4.1.3; fixed in 2.4.5, 4.1.3, 3.1.6

## Suggested inspection (read-only)
- `npm ls fast-uri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-uri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fph4-wmhf-6fwf (GitHub-reviewed advisory GHSA-fph4-wmhf-6fwf lists affected ranges: npm fast-uri >=2.4.1 =3.1.2 =4.0.0 <4.1.3)

Commands are suggestions: review each one before running it.

Loading voting…