Skip to content

← Actionable
High, CVSS 8.5amended

CodeWhale: rlm_eval auto-approves arbitrary Python execution, bypassing the user's approval policy (RCE)

CVE-2026-75858GHSA-wrj3-vj8c-784f

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm codewhale

    Affected
    >= 0.8.41, < 0.8.64
    Fixed in
    0.8.64
  • npm deepseek-tui

    Affected
    >= 0.8.33, < 0.8.41
    Fixed in
    0.8.41
  • crates.io codewhale-tui

    Affected
    >= 0.8.41, < 0.8.64
    Fixed in
    0.8.64
  • crates.io deepseek-tui

    Affected
    >= 0.8.33, <= 0.8.41
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-75858: 0.36% estimated exploitation activity in the next 30 days; percentile 30.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Maintainer resolution The CodeWhale maintainers validated this report. The affected package ranges are recorded in the advisory metadata. Version 0.8.64 contains the fix in commit 57f3c89471e27ac4032d9791f6885e5d4408c381. Users should upgrade to 0.8.64 or later. The original reporter analysis is preserved below. Summary The rlmeval tool runs an arbitrary Python string chosen by the model in a real python3 interpreter. Its approvalrequirement() returns ApprovalRequirement::Auto, which the engine treats as "never prompt," regardless of the user's configured --approval-policy. A single tool call — which prompt injection from any untrusted content the agent reads (a web page, a fetched URL, a repo file, an MCP tool result) can induce — runs code on the user's machine at the user's privilege with no prompt and no audit step. This is the same defect that was already patched on the sibling runtests tool (CVE-2026-45311); the fix never reached rlmeval or rlmopen, which expose a broader…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wrj3-vj8c-784f

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-wrj3-vj8c-784f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-75858

Advisory: CodeWhale: rlm_eval auto-approves arbitrary Python execution, bypassing the user's approval policy (RCE)
IDs: CVE-2026-75858, GHSA-wrj3-vj8c-784f
Record: https://patchnext.com/advisories/cve-2026-75858 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: codewhale 0.8.64; deepseek-tui 0.8.41; codewhale-tui 0.8.64. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm codewhale: affected >= 0.8.41, < 0.8.64; fixed in 0.8.64
- npm deepseek-tui: affected >= 0.8.33, < 0.8.41; fixed in 0.8.41
- crates.io codewhale-tui: affected >= 0.8.41, < 0.8.64; fixed in 0.8.64
- crates.io deepseek-tui: affected >= 0.8.33, <= 0.8.41

## Suggested inspection (read-only)
- `npm ls codewhale --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls deepseek-tui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- crates.io codewhale-tui: check the installed version with your package manager.
- crates.io deepseek-tui: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on codewhale, deepseek-tui, codewhale-tui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wrj3-vj8c-784f (OSV record GHSA-wrj3-vj8c-784f lists affected ranges: crates.io deepseek-tui >=0.8.33 =0.8.33 =0.8.41 =0.8.41 <0.8.64 (fixed))
- Verified: https://github.com/advisories/GHSA-wrj3-vj8c-784f (GitHub-reviewed advisory GHSA-wrj3-vj8c-784f lists affected ranges: crates.io deepseek-tui >=0.8.33 =0.8.33 =0.8.41 =0.8.41 <0.8.64)

Commands are suggestions: review each one before running it.

Loading voting…